This topic contains 12 replies, has 4 voices, and was last updated by  Thalamus 1 month, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #59332
     wrd1972 
    Participant
    Membervip

    So I have this weird issue with DOF. It is randomly NOT working when the table is first started. So once the table is loaded and started for the first time, the DOF most likely, not work. If I exit the table and re-enter (NO-reload), the DOF will likely be working fine. Its just bad about no working that first time and at random times after that. Problem happens with VP editor and PinballX.

    I am using 2 Sainsmart 8-relay boards, VP10.3.1 and VPM 2.9. This issue has started recently but I cant trace it back to VP or VPM updates. But I do know that it is very freaking annoying.

    Any ideas on how to resolve this?

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #59333
     randr 
    Keymaster
    ModeratorMember

    I’m not a huge fan of sainsmart relay boards as they fire all ports on power up and I just don’t like relays for flippers it adds another click sound that seems off when playing. Can you disconnect one and does it always work first time through pbx with just one sainsmart? Also not sure if dof supports the 16 port sainsmart but that way you would ably be addressing one pcb. I assume you have both serial numbers setup in dof config? Try it with one and see then try it with the other and see maybe one of them has a issue? Or move them to separate USB pairs on motherboard that may help a lot. Also pbx add a delay before starting table that may give sainsmart time to init

    #59351
     wrd1972 
    Participant
    Membervip

    Thanks randr. I will try didconnecting one like what you said. Last time i asked, the 16 relay was not compatable, but i sure wish it was. I put a timer on the niarss so they dont do their annoying post at start up. Yup, thats very annoying.

     

    What would you use in place of the sainsmart boards. I need 16 outputs for the dof and toys on the cab. Whats the most reliable solution?

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #59352
     randr 
    Keymaster
    ModeratorMember

    Also try a delay script of 100ms or something that you set in PBX before table launch you may need to just slow down frontend launch a titch

    #59366
     Arngrim 
    Participant
    DOF Minister

    same than Randr, not a fan of Sainsmart which looked a nice alternative than ledwiz and pacled but this should be more used but heavy consuming toys only

    for the Sainsmart 16 ports, i only know the relay board, so it is not a controller, or there is one that i don’t know

    #59456
     wrd1972 
    Participant
    Membervip

    Thanks guys.

     

    Arngrim,

    I was referring to this Sainsmart 16 relay board:

    https://www.sainsmart.com/relay-1/relays/sainsmart-imatic-16-channels-wifi-network-i-o-controller-kit-for-arduino-relay-android-ios.html

    So would this be supported?

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #62448
     wrd1972 
    Participant
    Membervip

    Okay now considering replacing the Sainsmart boards. Still a bit confused regarding the most popular boards for DOF. I am seeing Ledwiz, pacled and booster boards. I currently have 12 solenoids to support, and a few lights.

    And what is a booster board?

    Can you guys please link me to what you reccomend?

    Thanks

     

     

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #62454
     randr 
    Keymaster
    ModeratorMember

    I use 2 ledwiz’ s no booster just plain relays for a knocker, strobes, becans, gear motor  and a blower. Everything else is direct to ledwiz.  Now I do use contractors not starter solenoids for 10 solenoids so they just hook right up to ledwiz. I just purchase the ledwiz from Groozygamer web site (the manufacturer

    #62477
     wrd1972 
    Participant
    Membervip

    Im using starter solenoids so if I am correct. I need to have relays or the booster board. If the booster board simply connects to the relays, that sounds like a lot less wiring than relays. Is that correct?

    Do you know how many outputs there are on the booster board?

     

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #62478
     randr 
    Keymaster
    ModeratorMember

    Im not sure about the booster boards never used them. I think each booster can run several solenoids but im not sure. ask @zebulon he’s a great guy

    • This reply was modified 1 month, 3 weeks ago by  randr.
    #62487
     wrd1972 
    Participant
    Membervip

    @zebulon

    Can I please get an understanding of the booster boards? I need to control 10 solenoids. I am looking to replace my two Sainsmart 8-relay boards and I am still confused as to what HW I need.

     

    Thanks

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #63392
     wrd1972 
    Participant
    Membervip

    I think I may have found the reason for this issue. I did a complete reinstall of the DOF files and the problem appears to be fixed. I know that just recently, when I had my SSD issues, I was copying large chunks of data including the Directoutput folder, from an old drive to a new drive. It appears that the copy was not accurate and/or there was some possible registry items that may have been missing or corrupted. Should have just done a clean DOF re-install.

    Gonna do some more testing,. But it does appear to be fixed.
    Thanks all.
    -B

    My VP Pincab /MAME Arcade Specs: Dell T3400 workstation with Core2 Quad core 3.0GHZ (Q9650) CPU - 8GB of RAM - Nvidia 760GTX (MSI Twin Frozr)

    40" PF Sony gaming LED TV, 22" upper and 19" lower monitors in the backbox - Virtuapin controller w/ analog plunger - Full DOF - Full MAME arcade support

    #63406
     Thalamus 
    Participant
    ContributorMember

    … remember the DjRobX update

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

©2017 VPinBall.com

Facebook Auto Publish Powered By : XYZScripts.com

Log in with your credentials

or    

Forgot your details?

Create Account