This topic contains 179 replies, has 42 voices, and was last updated by  HauntFreaks 3 months ago.

Viewing 20 posts - 161 through 180 (of 180 total)
  • Author
    Posts
  • #46964
     grunger 
    Participant

    did somebody else notice there is a delay when the upper right flipper is triggered, compared to the right flipper, they should be in sync, this is making the shots to the left ramp, or the train very difficult because we have to anticipate the shot to compensate the delay. i don’t know if this is controlled by the physics parameters of the flipper1, don’t understand the physic settings, or if it is a vpm problem, because it is a different solenoid than the flipper solenoid themselves

    Ah – I noticed I couldn’t hit the train very often! That would be why!

    #46966
     STAT 
    Participant
    MemberContributor

    Thats true, some of the Phys Settings at Flipper1 are different to the Main Flippers …
    Maybe you want to try this Settings at Options/Flipper1 …
    Note: havent tested before …

    Attachments:
    #46978
     Arngrim 
    Participant
    DOF Minister

    i tried some, didn’t help, but i don’t like to do something that i don’t understand, maybe slider can comment on the values and possible improvements?

    #46991
     Sliderpoint 
    Participant
    MemberContributor

    On the version I’m using the upper right flipper and lower flippers all have the same settings.  So feel free to change the settings it’s not going to harm anything as far as I could see.

    One thing that is interesting is that the manual shows that the lower flippers, upper right and upper left all have different coils (red,orange and yellow).  I’m not sure if the ROM is some how accounting for the different power on the coils or not.   I am not using any of the code ideas to bypass VPM for flipper control (mainly because of the ROM controlled flipping that happens)  so I suppose it’s possible it could be a VPM thing but I wouldn’t know how to check something like that.  But as far as VP code all the flippers are activated the same. push button>solCallback>rotateflipper to end.

    You could try making the primitive flippers not visible and making the default flippers visible to see if it’s something with those and the timer that keeps those in sync.

    -Mike

    #47022
     STAT 
    Participant
    MemberContributor

    arngrim, i would leave it as it is – i couldnt see any diff. in Game, and hit Train also … not always, but mostly

    #47169
     Arngrim 
    Participant
    DOF Minister

    i tried to switch the primitive and flipper visibility but it is the same, for the flipper settings i don’t understand them but i tried some changes and it doesn’t change either

    fact is when i press the right flipper and i try to have the both right flippers in my eyes, it seems there is tiny delay between the low and the up flipper triggered, i miss most of the time my shots on the upper right flipper because i don’t think all the time to compensate the delay, my knowledge here is limited to find the root cause of the issue

    #47182
     Sliderpoint 
    Participant
    MemberContributor

    I think this is definitely related to VPM and/or the core scripting.   But as a solution you can do this, add the flipper1 rotation to the SolRFlipper sub. and comment it out of the SolURFlipper sub.   Like this:

    Sub SolRFlipper(Enabled)
    If Enabled Then
    RightFlipper.RotateToEnd
    Flipper1.RotateToEnd
    PlaySound SoundFX(“fx_flipperup”,DOFFlippers), 0, .4, 0.05, 0.05
    Else
    RightFlipper.RotateToStart
    Flipper1.RotateToStart
    PlaySound SoundFX(“fx_flipperdown”,DOFFlippers), 0, .4, 0.05, 0.05
    End If
    End Sub

    Sub SolURFlipper(Enabled)
    If Enabled Then
    ‘ Flipper1.RotateToEnd
    ‘ PlaySound SoundFX(“fx_flipperup”), 0, 1, 0.05, 0.05
    Else
    ‘ Flipper1.RotateToStart
    ‘ PlaySound SoundFX(“fx_flipperdown”), 0, 1, 0.05, 0.05
    End If
    End Sub

    You can also do the same thing with Flipper2, but you can’t comment it out of SolULFlipper sub or the thing flips won’t work. Like this:

    Sub SolLFlipper(Enabled)
    If Enabled Then
    LeftFlipper.RotateToEnd
    Flipper2.RotateToEnd
    PlaySound SoundFX(“fx_flipperup”,DOFFlippers), 0, .4, -0.05, 0.05
    Else
    LeftFlipper.RotateToStart
    Flipper2.RotateToStart
    PlaySound SoundFX(“fx_flipperdown”,DOFFlippers), 0, .4, -0.05, 0.05
    End If
    End Sub

    The only odd thing that I can think is that when you get the auto flip at ball drain it will include the upper right flipper.  So not really a big deal.  But this should remove the lag difference between the upper and lower flippers.

    -Mike

    #47183
     randr 
    Keymaster
    ModeratorMember

    On my real Addams it works same way! There are two optos and you can see same thing so I think it’s spot on as is. On real machine you press flipper in slowly it triggers lower flipper first then 2nd flipper Opto much later is triggered

    #47184
     Sliderpoint 
    Participant
    MemberContributor

    edit:  double-ish post because of browser issues

    -Mike

     

    #47248
     Arngrim 
    Participant
    DOF Minister

    it works great, thanks Slider :)

    for the thing flips, we can just question if lflipperkey is activated or not, if not, trigger the solulflipper

     

    ‘Flippers
    Sub SolRFlipper(Enabled)
    If Enabled Then
    RightFlipper.RotateToEnd
    Flipper1.RotateToEnd
    PlaySound SoundFX(“fx_flipperup”,DOFFlippers), 0, .4, 0.05, 0.05
    Else
    RightFlipper.RotateToStart
    Flipper1.RotateToStart
    PlaySound SoundFX(“fx_flipperdown”,DOFFlippers), 0, .4, 0.05, 0.05
    End If
    End Sub

    Sub SolURFlipper(Enabled)
    ‘If Enabled Then
    ‘ Flipper1.RotateToEnd
    ‘ PlaySound SoundFX(“fx_flipperup”), 0, 1, 0.05, 0.05
    ‘ Else
    ‘ Flipper1.RotateToStart
    ‘ PlaySound SoundFX(“fx_flipperdown”), 0, 1, 0.05, 0.05
    ‘ End If
    End Sub

    Sub SolLFlipper(Enabled)
    If Enabled Then
    LeftFlipper.RotateToEnd
    Flipper2.RotateToEnd
    PlaySound SoundFX(“fx_flipperup”,DOFFlippers), 0, .4, -0.05, 0.05
    Else
    LeftFlipper.RotateToStart
    Flipper2.RotateToStart
    PlaySound SoundFX(“fx_flipperdown”,DOFFlippers), 0, .4, -0.05, 0.05
    End If
    End Sub
    Sub SolULFlipper(Enabled)
    If LeftFlipperButton = 0 Then
    If Enabled Then
    Flipper2.RotateToEnd
    PlaySound SoundFX(“fx_flipperup”,DOFFlippers), 0, .1, -0.05, 0.05
    Else
    PlaySound SoundFX(“fx_flipperdown”,DOFFlippers), 0, .1, -0.05, 0.05
    Flipper2.RotateToStart
    End if
    End If
    End Sub

     

    but honestly, since the beginning of your taf releases, the thing flips never work as it should here, it is always delayed, flipper activated too late to hit the ball

    #56849
     blackvulcan3 
    Participant

    I couldnt get this to play in 10.3 3088. I removed the FS from the inclination error line (Line 160 I think).

    I have also changed the table settings for a cabinet at this seems to be set up for DT. Hope that helps someone. It looks good, not perfect but a lot better.

     


    Some users who have liked this topic:

    • avatar
    Attachments:
    #56852
     Sliderpoint 
    Participant
    MemberContributor

    Oh yeah, I guess I didn’t post info here. Comment out lines 84 and 94 to work in 10.3 beta.

    And the display settings are not set for desktop, just not for landscape.


    Some users who have liked this topic:

    • avatar
    • avatar
    1 user thanked author for this post.
    #56853
     HauntFreaks 
    Moderator
    vipContributorMember

    Oh yeah, I guess I didn’t post info here. Comment out lines 84 and 94 to work in 10.3 beta. And the display settings are not set for desktop, just not for landscape.


    Some users who have liked this topic:

    • avatar
    • avatar
    #56857
     Sliderpoint 
    Participant
    MemberContributor

    Lol


    Some users who have liked this topic:

    • avatar
    #59107
     Mirkin 
    Participant

    Should this tble work on V10.3. I get an errorat line 94 and can only run it with v10.2.

    Still totally cool though :-)

     

    #59111
     Sliderpoint 
    Participant
    MemberContributor

    Should this tble work on V10.3. I get an errorat line 94 and can only run it with v10.2. Still totally cool though :-)

    Was answered literally three posts up.


    Some users who have liked this topic:

    • avatar
    #59113
     randr 
    Keymaster
    ModeratorMember

    Seems very few people read. lol I get pm’s everyday asking questions when they could ask in forums or look in forums. :(


    Some users who have liked this topic:

    • avatar
    #61053
     Zozueh 
    Participant

    OK. Managed to rotate the table but it is all stretched.  :scratch:

    I know it is the backdrop settings, but I copied some from posts of another famous forum like this and the result was not very good.

    I guess I´ll have to play it with the strange graphics. Gameplay wise it´s nice, though.  :yes:

    (Haven´t played the real table)

    • This reply was modified 3 months ago by  Zozueh.
    #61864
     jbg4208 
    Participant
    Member

    Give this a one a try. Adjust as needed on your cab.

     


    Some users who have liked this topic:

    • avatar
    Attachments:
    #61866
     HauntFreaks 
    Moderator
    vipContributorMember

    Seems very few people read. lol I get pm’s everyday asking questions when they could ask in forums or look in forums. :(

    thanks :(   i’m sorry….     :cry:

Viewing 20 posts - 161 through 180 (of 180 total)

You must be logged in to reply to this topic.

©2017 VPinBall.com

Facebook Auto Publish Powered By : XYZScripts.com

Log in with your credentials

or    

Forgot your details?

Create Account