This topic contains 244 replies, has 60 voices, and was last updated by Profile gravatar of CarnyPriest CarnyPriest 4 days, 14 hours ago.

Viewing 20 posts - 41 through 60 (of 245 total)
  • Author
    Posts
  • #44196
    Profile gravatar of Drybonz Drybonz 
    Participant
    Member

    It seems like since the plastics are on the big image (twdplasticslowres) that we could delete the individual 1024 plastics, right? At least reduce file size a little.

    So, it’s actually using all those 1024 plastics.  Wondering if those are a big part of the memory usage.

    0
    #44197
    Profile gravatar of DJRobX DJRobX 
    Participant
    Member

    I will try brute force 4x and see what happens.

    This table will go definitely go slow.  But check out the ramps on Gilligan’s with it on vs. off.

    0
    #44198
    Profile gravatar of ckpin ckpin 
    Participant

    Awesome!  Thanks for the wonderful holiday gift.  It is working well (W7 – i7 – GTX660).  Of course,  the number of balls and replays needed adjusting so it could be more fully tested. :good:

    0
    #44199
    Profile gravatar of DJRobX DJRobX 
    Participant
    Member
    It didn’t seem to give me the same benefit… even after restarting. I’m wondering if there’s a way to apply the “max texture” option to only this table, so that we don’t have to change it each time we play this one.

    Yep, I confirmed.   If you set max texture size to 2048, only two images are resized:

    4096×1765 -> 2048×882
    4096×512 -> 2048×256
    0
    #44200
    Profile gravatar of Drybonz Drybonz 
    Participant
    Member

    I turned off the animations on the head and bike girl, and that seems to maybe have made a bit of difference… but it’s a mixed bag.  With the same settings, I can get a smooth ball, then later get stutter, and sometimes even a crash when I first start it.

    I also noticed that the main general “light” doesn’t come on sometimes when you first start, so I’m wondering if this is VPM related?

    0
    #44201
    Profile gravatar of Drybonz Drybonz 
    Participant
    Member

    Here’s a screenshot of the table with my personal environment, light and material setup.

    vpinballx-2016-12-20-00-48-46-62

    0
    Attachments:
    You must be logged in to view attached files.
    #44205
    Profile gravatar of DJRobX DJRobX 
    Participant
    Member

    I also noticed that the main general “light” doesn’t come on sometimes when you first start, so I’m wondering if this is VPM related?

    The short delay for the light is a known issue in the emulation, but has nothing to do with performance of the table.   The ROM wants some sort of response from the LED controller board before it starts sending the LED strings.     After 2-3 minutes it gives up and starts transmitting.   Since I don’t have a TWD LE machine, I have no way of knowing what that response is supposed to be.   In Mustang LE I was able to hack the ROM code to transmit immediately.   TWD LE seems more complicated, but I found that if I just blast a bunch of the same character, it will start transmitting fairly quickly, so that was the hack approach I went with for that table as there’s a higher chance it will work with updates from Stern.

    I had an earlier WIP of the table and it doesn’t have any performance problems.   There’s a lot more going on in this version, and performance suffers as a result.  It does work great on my cab now with those two textures reduced, though.   I’ve been playing for hours and no stutters whatsoever.   My cab reacted similar to what you were describing when I set it to 3072.   So I suspect your performance is just shy of what’s needed to run it smoothly.

    The crash at startup we’ve all been talking about for a while now – it’s a failure to allocate memory and is unrelated to the lights, or slow table performance (assuming your machine has enough memory of course).   The 64 bit version of VP and VPM might help there.

    1+

    Some users who have liked this topic:

    • avatar
    #44209
    Profile gravatar of DJRobX DJRobX 
    Participant
    Member

    Hmmm? I’m not getting a light show :( Latest everything installed, tried going back through older vpinmames but still no luck. I’m stumped :(

    Have you updated your B2S?   The release version of B2s has a 160 light limit, which is not enough to cover the extended LE lights.

    0
    #44210
    Profile gravatar of RustyCardores RustyCardores 
    Participant
    Member

    Hmmm? I’m not getting a light show :( Latest everything installed, tried going back through older vpinmames but still no luck. I’m stumped :(

    Have you updated your B2S?   The release version of B2s has a 160 light limit, which is not enough to cover the extended LE lights.

    Yep. Unless I updated to the wrong version??

    Edit: I should say that by light show I mean just normal table lights, not DOF LEDs or anything.

    As you can see in this image there are no lights under the slingshots or up on the back wall etc

    Sent from my iPhone using Tapatalk

    0
    #44211
    Profile gravatar of -=Dozer=- -=Dozer=- 
    Participant

    I’m cooking up a small update with some texture resizes based on the information here.  I totally missed those two large images and I’ve also put a bit of code in for the forthcoming directb2s.

    The video below is unrelated to this post really but I’m leaving it here for Dark to check out.  The other night he rendered 255 images of a gradual light swell on the the right hand side of the well walker  and today I imported them and recorded the result.  You can see the smooth transition of light on his right hand side (disregard the flash that occurs on his face from time to time).

    This image import took the table size to 620MB LOL.  But it still loads and runs like a champ!

    https://www.youtube.com/watch?v=NnNWtOLpFJc&feature=youtu.be

    0
    #44219
    Profile gravatar of Mark70 Mark70 
    Participant
    Member

    Regarding to ball stutter,  I disabled playfield reflection and the table runs smooth like silk with brute force 4x AA enabled.
    But I did not check yet, if the lack of playfield reflection has a big visual impact on this table. Usually I leave it enabled.

    1+

    Some users who have liked this topic:

    • avatar
    #44221
    Profile gravatar of Drybonz Drybonz 
    Participant
    Member

    Good call, Mark… that seems to have some benefit for me as well.

    0
    #44222
    Profile gravatar of Winterpooch Winterpooch 
    Participant

    fantastic looking table and it plays great. i have some issues when using pin2dmd though – the pin2dmd slows down to a crawl when ball 3 is completed and it takes forever to get to game over state. also, sometimes when the crossbow is loaded, also the pin2dmd slows down to a crawl, all animations are slow etc. i got all the latest .dlls and vpm and the LE rom and double cheese and bbq sauce just to be on the safe side. does anyone else have issues with this table when running pin2dmd ?

    another issue i have is if i tilt the game when the ball is loaded in the crossbow. the game can’t seem to deal with it and it stays in tilt mode. it tries to eject then find balls endlessly without success, need to reset.

    when it does run, it plays beautifully on my machine, no stutter at all. (i5, 970gtx, 8gb)

     

    0
    #44231
    Profile gravatar of -=Dozer=- -=Dozer=- 
    Participant

    Version 1.1 has been uploaded with some very small changes – if you’re experiencing a hang up when the game starts this version may help.

    Anyone who is experiencing no GI or RGB insert lightning, then there’s something up with your directb2s server installation or version of VPM. Make sure you are using the versions linked in the description for this table.  I’m not sure what is causing the weird slowdowns with real DMD’s (although I’ve only seen 1 report of this).  I don’t have a real DMD so cannot test sorry.

    Oh I forgot to mention, the crossbow fire button is mapped to both right magnasave and also enter (ball launch).

    6+

    Some users who have liked this topic:

    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    2 users thanked author for this post.
    #44233
    Profile gravatar of Ginsonic Ginsonic 
    Participant

    Thanks a lot  :yahoo:   :good:

    0
    #44234
    Profile gravatar of randr randr 
    Keymaster
    ModeratorMember

    Thanks dozer! The upload worked that time I assume.

    0
    #44238
    Profile gravatar of senseless senseless 
    Participant
    Member

    Thanks Dozer for the 1.1 update. This solved the rom error. Whatever I tried I could not get the 1.0 version to start. I’m 100% confident everything is up to date in my cab (Mustang and Ster Trek LE run fine).

    This version runs butter smooth with brute force enabled and all the other eye candy graphix options :).

    Time to set a nice high score and kill me some zombies!

     

    UPDATE: Grrrrrr I was just lucky.. now it give me the error again.

    I’m done with it. Just can’t get this one to run… really frustrating. Will give it a try later…

     

    0
    #44242
    Profile gravatar of Drybonz Drybonz 
    Participant
    Member

    I think the image in the backglass included with the 1.1 download is the Pro version.  Does anyone know for sure?  The backglass I got from VPU is different.  They are pretty similar though.

    0
    #44243
    Profile gravatar of LTA LTA 
    Participant

    FYI The backglass image on the 1.1 directb2s is the PRO backglass. The LE backglass has the bloody hand print and the spider web around the center.

    PRO: http://ipdb.org/showpic.pl?id=6155&picno=62834

    LE: http://ipdb.org/showpic.pl?id=6156&picno=63253

     

    0
    #44245
    Profile gravatar of -=Dozer=- -=Dozer=- 
    Participant

    Thanks dozer! The upload worked that time I assume.

    Yeah tanks man – worked fine tonight :)

    0
Viewing 20 posts - 41 through 60 (of 245 total)

You must be logged in to reply to this topic.

©2017 VPinBall.com

Facebook Auto Publish Powered By : XYZScripts.com

Log in with your credentials

or    

Forgot your details?

Create Account