• Don't forget to rate 1-5 stars! Check the support tab for any help or comments.

  • (2)
    « »

    The 3 on 1 Tron Legacy PuP-Pack!

    A video preview of all the VPX Tron Legacy PuP-Packs can be seen here:

    https://www.youtube.com/watch?v=vfgPrgyTH1s&t

     

    The 3 on 1 Pack: PuP Backglass, PuP Topper, DMD (PinMAME or DMDExt) are all on the Backglass screen.

    For those who MUST have their virtual DMD on the backglass screen (16:9) and don't have room for anything else. If you have a "square" backglass screen, then you can try the other two packs ("Max Pack" or "2 on 1") and have the DMD below the PuP Backglass.

    This Pack uses still image overlays for the new "framed" neon border. This overlay will change neon colours for game modes as well, but only has single colour transparency, and can't have animated neon or flares, or other animation on the border, so it's not as nice looking as the "Max Pack".

    You need to position your virtual DMD at the bottom center of the PuP Backglass.

    This PuP-Pack uses: (1 Backglass video layer, 2 Topper video layers, virtual DMD Layer, 1 Overlay layer)

     

    Requirements: IMPORTANT!

    PinUP System FULLY installed and PinUP Player setup (which contains PinUP Player 1.3+, PuPB2S driver, and PuPCapture files).

    You also MUST be updated to PinUP System 1.3.4 or higher!

    http://www.nailbuster.com/wikipinup/doku.php?id=release_notes

    DMDExt / Freezy 1.7 or higher installed in VPinMAME folder and configured to enable PUP! This must be installed AFTER PinUP System is installed! (to ensure you have the 1.7 or higher files!)

    "Use External DLL" must be enabled in PinMAME settings for trn_174h

    PuPCapture MUST be working:

    This PuP-Pack relies on monitoring the pinmame DMD for specific images to trigger videos. This needs both the freezy 1.7+ "dmddevice.dll" file, and the Pinup Player "dmddevicePUP.dll" file.

    Ensure PuPCapture is enabled in the dmddevice.ini file (in your VPinMAME folder):

    [pinup]

    enabled=true

    Note: If you are using a real DMD, then ensure that the freezy virtual DMD is disabled in the dmddevice.ini file:

    ; a DMD that renders with nice dots on a computer monitor

    [virtualdmd]

    enabled = false

     

    You CANNOT use any older version of PinUP Player as it won't work correctly! Must be 1.3 or higher!

     

    Older PuP-modded Tron Legacy Tables:

    You CANNOT use ANY PuP modded tables with this PuP-Pack!

    DO NOT use the "Tron Legacy PuP-Edition" or the "Tron Legacy PuP-Pack Edition" tables (or any table based on those!)

     

    You can however use this with any normal version of Tron Legacy LE VPX.

     

    No directb2s Backglass Running:

    You MUST NOT have a directb2s running at all, or it will obscure the PuP Backglass!!!

    Simply make sure you have a copy of your favorite Tron table (intended only for use with this PuP-Pack), and make sure it is named VERY differently to your directb2s file, so when you launch that copy of your Tron Legacy table it won't launch the directb2s!

     

    DMDs can now be ANY colour (or DMD colour mod) you want! This is a NEW feature with Freezy 1.7+ files installed! There is no longer a requirement to have your DMD colours match the PuPCapture files!

     

    Your DMD must be in English for all PuPCapture video triggers to work correctly!

     

    System:  Visual Pinball X (version 10.5+)

    PuP-Pack: All Video, Media and Artwork by TerryRed. PuP-Pack Editor & PuPCapture files by TerryRed

     

    Installation:

    Ensure there are no files in your "PUPVideos   trn_174h" folder (if that folder already exists).

    Copy the PuP-Pack "trn_174h" folder from the archive into your PUPVideos folder.

     

    For problems getting a PuP-Pack to work, refer to the wiki:

    http://www.nailbuster.com/wikipinup/doku.php?id=puppack_troubleshoot

    DMDExt / Freezy 1.7 or higher installed in VPinMAME folder and configured to enable PUP! This must be installed AFTER PinUP System is installed! (to ensure you have the 1.7 or higher files!)

    "Use External DLL" must be enabled in PinMAME settings for trn_174h

    PuPCapture MUST be working:

    This PuP-Pack relies on monitoring the pinmame DMD for specific images to trigger videos. This needs both the freezy 1.7+ "dmddevice.dll" file, and the Pinup Player "dmddevicePUP.dll" file.

    Ensure PuPCapture is enabled in the dmddevice.ini file (in your VPinMAME folder):

    [pinup]

    enabled=true

    Note: If you are using a real DMD, then ensure that the freezy virtual DMD is disabled in the dmddevice.ini file:

    ; a DMD that renders with nice dots on a computer monitor

    [virtualdmd]

    enabled = false

     

    Your DMD must be in English for all PuPCapture video triggers to work correctly!

     

    Installation:

    Ensure there are no files in your "PUPVideos   trn_174h" folder (if that folder already exists).

    Copy the PuP-Pack (trn_174h) folder from the archive into your PUPVideos folder.

     

    For problems getting a PuP-Pack to work, refer to the wiki:

    http://www.nailbuster.com/wikipinup/doku.php?id=puppack_troubleshoot

    3 on 1 Pack

    V1.2

    -updated screens config (Topper Layer 2, ForcePopBack) to work correctly with PinUPSystem 1.3.4+

    V1.1

    - removed pupinit.bat file, as it may have been blocked for some users and cause a pop-up when playing. This file was only used as a way to try to keep VPX in focus after PuP was initialized. Not normally needed.

    This topic contains 5 replies, has 2 voices, and was last updated by  TerryRed 1 month, 2 weeks ago.

    Viewing 6 posts - 1 through 6 (of 6 total)
    • Author
      Posts
    • #83099
       TerryRed 
      Moderator
      MemberContributorModerator

      The 3 on 1 Tron Legacy PuP-Pack!

      A video preview of all the VPX Tron Legacy PuP-Packs can be seen here:

      https://www.youtube.com/watch?v=vfgPrgyTH1s&t

       

      The 3 on 1 Pack: PuP Backglass, PuP Topper, DMD (PinMAME or DMDExt) are all on the Backglass screen.

      For those who MUST have their virtual DMD on the backglass screen (16:9) and don't have room for anything else. If you have a "square" backglass screen, then you can try the other two packs ("Max Pack" or "2 on 1") and have the DMD below the PuP Backglass.

      This Pack uses still image overlays for the new "framed" neon border. This overlay will change neon colours for game modes as well, but only has single colour transparency, and can't have animated neon or flares, or other animation on the border, so it's not as nice looking as the "Max Pack".

      You need to position your virtual DMD at the bottom center of the PuP Backglass.

      This PuP-Pack uses: (1 Backglass video layer, 2 Topper video layers, virtual DMD Layer, 1 Overlay layer)

       

      Requirements: IMPORTANT!

      PinUP System FULLY installed and PinUP Player setup (which contains PinUP Player 1.3+, PuPB2S driver, and PuPCapture files).

      You also MUST be updated to PinUP System 1.3.4 or higher!

      http://www.nailbuster.com/wikipinup/doku.php?id=release_notes

      DMDExt / Freezy 1.7 or higher installed in VPinMAME folder and configured to enable PUP! This must be installed AFTER PinUP System is installed! (to ensure you have the 1.7 or higher files!)

      "Use External DLL" must be enabled in PinMAME settings for trn_174h

      PuPCapture MUST be working:

      This PuP-Pack relies on monitoring the pinmame DMD for specific images to trigger videos. This needs both the freezy 1.7+ "dmddevice.dll" file, and the Pinup Player "dmddevicePUP.dll" file.

      Ensure PuPCapture is enabled in the dmddevice.ini file (in your VPinMAME folder):

      [pinup]

      enabled=true

      Note: If you are using a real DMD, then ensure that the freezy virtual DMD is disabled in the dmddevice.ini file:

      ; a DMD that renders with nice dots on a computer monitor

      [virtualdmd]

      enabled = false

       

      You CANNOT use any older version of PinUP Player as it won't work correctly! Must be 1.3 or higher!

       

      Older PuP-modded Tron Legacy Tables:

      You CANNOT use ANY PuP modded tables with this PuP-Pack!

      DO NOT use the "Tron Legacy PuP-Edition" or the "Tron Legacy PuP-Pack Edition" tables (or any table based on those!)

       

      You can however use this with any normal version of Tron Legacy LE VPX.

       

      No directb2s Backglass Running:

      You MUST NOT have a directb2s running at all, or it will obscure the PuP Backglass!!!

      Simply make sure you have a copy of your favorite Tron table (intended only for use with this PuP-Pack), and make sure it is named VERY differently to your directb2s file, so when you launch that copy of your Tron Legacy table it won't launch the directb2s!

       

      DMDs can now be ANY colour (or DMD colour mod) you want! This is a NEW feature with Freezy 1.7+ files installed! There is no longer a requirement to have your DMD colours match the PuPCapture files!

       

      Your DMD must be in English for all PuPCapture video triggers to work correctly!

       

      System:  Visual Pinball X (version 10.5+)

      PuP-Pack: All Video, Media and Artwork by TerryRed. PuP-Pack Editor & PuPCapture files by TerryRed

       

      Installation:

      Ensure there are no files in your "PUPVideos   trn_174h" folder (if that folder already exists).

      Copy the PuP-Pack "trn_174h" folder from the archive into your PUPVideos folder.

       

      For problems getting a PuP-Pack to work, refer to the wiki:

      http://www.nailbuster.com/wikipinup/doku.php?id=puppack_troubleshoot


      Some users who have liked this topic:

      • avatar
      1 user thanked author for this post.
      #83123
       TerryRed 
      Moderator
      MemberContributorModerator

      If Windows Defender gives you issues with pininit.bat (included with the PuP-Pack)….

      Make sure it’s not blocked. If you must, create an exception in Windows Defender for the entire PinUPSystem folder or that file if you need to….or you can try removing the file. That file is only used to try to keep VPX in focus after the PuP-Pack is loaded.

      #83226
       robertms 
      Participant
      Member

      Hey Terry, fantastic work! I haven’t added PUP to my cab yet but I tried the 3-on-1 on my dual-screen desktop and the effect is WOW! For the first time I can honestly say the second screen is a great enhancement to desktop play. Thanks for everything you do! :good:


      Some users who have liked this topic:

      • avatar
      #87124
       TerryRed 
      Moderator
      MemberContributorModerator

      V1.2

      -updated screens config (Topper Layer 2, ForcePopBack) to work correctly with PinUPSystem 1.3.4+

      You MUST be updated to PinUP System 1.3.4!

      http://www.nailbuster.com/wikipinup/doku.php?id=release_notes

      #87126
       TerryRed 
      Moderator
      MemberContributorModerator

      If you already have v1.1 of the “3 on 1” or “2 on 1” PuP-Pack installed…. (and using PinUP System 1.3.4) you can just use the PuP-Pack editor to change Topper 2 (Screen 8) to “ForcePopBack” instead of downloading the entire PuP-Pack again.


      Some users who have liked this topic:

      • avatar
      #90128
       TerryRed 
      Moderator
      MemberContributorModerator

      DMDs can now be ANY colour (or DMD colour mod) you want! This is a NEW feature with Freezy 1.7+ files installed! There is no longer a requirement to have your DMD colours match the PuPCapture files!

    Viewing 6 posts - 1 through 6 (of 6 total)

    You must be logged in to reply to this topic.

  • Please login to download.

  • ©2018 VPinBall.com

    WP Facebook Auto Publish Powered By : XYZScripts.com
    Vpinball.com

    Log in with your credentials

    or    

    Forgot your details?

    Create Account