Currently, there are 0 users and 0 guests visiting this topic.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #177962
    Everly
    Participant
    @everly

    So I just never got into Future Pinball, all my tables are VPX and FX3.  But Terry Red and Major Frenchy (both of whom I have super respect for) spoke highly of it and there are some tables that I’m interested in that don’t exist anywhere else.  So I followed Terry’s Mega guide and worked through the steps.  For the most part I have working tables and DOFLinx is sending my solenoids ballistic on them so that is all working.  I haven’t started fighting with getting my real DMD to work yet because of this first problem I haven’t been able to solve.

    I can’t get my backglass to show correctly.  In video rendering I have backglass set to Display #2 and the same resolution as in my display settings but the BG only displays on 1/2 my monitor.  If I press Q to get into the BAM settings I can move it but it just disappears when it gets to that half point.  I noticed that when I am in Video Rendering the Widescreen option is disabled for the BG.  Basically, BAM or FP appears to think my monitor is half the size it is and it.  My PF is portrait and my BG is landscape, not sure if that has something to do with it.  The screens are aligned along the top as they should be with the PF to the left.

    I followed Terry’s settings in the Mega guide so I’m not sure what I’m missing.  Thanks in advance for any help.

    #177969
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    So I just never got into Future Pinball, all my tables are VPX and FX3. But Terry Red and Major Frenchy (both of whom I have super respect for) spoke highly of it and there are some tables that I’m interested in that don’t exist anywhere else. So I followed Terry’s Mega guide and worked through the steps. For the most part I have working tables and DOFLinx is sending my solenoids ballistic on them so that is all working. I haven’t started fighting with getting my real DMD to work yet because of this first problem I haven’t been able to solve.

    I can’t get my backglass to show correctly. In video rendering I have backglass set to Display #2 and the same resolution as in my display settings but the BG only displays on 1/2 my monitor. If I press Q to get into the BAM settings I can move it but it just disappears when it gets to that half point. I noticed that when I am in Video Rendering the Widescreen option is disabled for the BG. Basically, BAM or FP appears to think my monitor is half the size it is and it. My PF is portrait and my BG is landscape, not sure if that has something to do with it. The screens are aligned along the top as they should be with the PF to the left.

    I followed Terry’s settings in the Mega guide so I’m not sure what I’m missing. Thanks in advance for any help.

    It’s normal to not get the widescreen option for the Backglass in FP.

    Change the BAM Backglass option to Stretch to fill the screen. This will tell you how far FP and BAM are able to go.

    If it doesn’t fill the whole screen, it sounds like FP’s backglass resolution is not set to the right resolution possibly (even though you think it is). FP will change the resolution of that monitor in Windows to whatever resolution it has set. Many people don’t notice the resolution isnt correct when changing around the buttons.

    If needed, try changing the FP backglass to windowed with a similar resolution and see if it will at least allow you to fill it correctly. Then troubleshoot from there.

    #178002
    Everly
    Participant
    @everly

    Thank you for the direction.  I see the affect that has but it isn’t want we are wanting.  I did notice that when I uncheck Full Screen the resolution is set to a landscape configuration (which my monitor is).  So I went with 1028×728 and that gave me a window of the right proportions in the center of the screen but I couldn’t resize it any larger.  In the BAM menu if I tried to scale it higher the picture would just start getting larger than the window but wouldn’t make the window any larger.

    I also noticed that when I clicked Full Screen all of the resolution options I could choose from would be in a portrait configuration, like 728×1028 smaller number was always first.  I can change to the largest resolution but it is staying in portrait configuration and it won’t fill a landscape oriented monitor.

    If any screen captures would help please let me know.

    #178015
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    Thank you for the direction. I see the affect that has but it isn’t want we are wanting. I did notice that when I uncheck Full Screen the resolution is set to a landscape configuration (which my monitor is). So I went with 1028×728 and that gave me a window of the right proportions in the center of the screen but I couldn’t resize it any larger. In the BAM menu if I tried to scale it higher the picture would just start getting larger than the window but wouldn’t make the window any larger.

    I also noticed that when I clicked Full Screen all of the resolution options I could choose from would be in a portrait configuration, like 728×1028 smaller number was always first. I can change to the largest resolution but it is staying in portrait configuration and it won’t fill a landscape oriented monitor.

    If any screen captures would help please let me know.

    I told you to try running the FP BG in windowed to help narrow down what is happening… not as a solution to fix the problem.

     

    You need to figure out if FP is actually changing your backglass resolution correctly to match your monitor’s native resolution (and not switching to a different resolution). Check you monitor / TV “info” button to show what resolution and Hz its running in.

    You also need to be absolutely sure your playfield monitor and Backglass monitor have Text Scaling set to 100% on BOTH. Then reboot.

     

    You can check the Future Pinball settings in the windows registry to see what settings are being used for the backglass resolution. (check with FP closed)

    Computer\HKEY_CURRENT_USER\Software\Future Pinball\GamePlayer

     

    This is where most people have problems because they don’t understand that FP is unique in that it will launch TWO fullscreen windows… and FP WILL change the resolution of your backglass in Windows settings (if incorrectly set) when it’s run in Fullscreen. So FP could be changing your 2nd screen to something like 1024×768.

     

    1 user thanked author for this post.
    #178088
    Everly
    Participant
    @everly

    I told you to try running the FP BG in windowed to help narrow down what is happening… not as a solution to fix the problem.

    (Whoa..flash back to 2nd grade when the teacher yelled at me)

    I went into the Registry and changed the Second Monitor Height and Width to 1200 and 1920 and that got me where I wanted to be.  Now the BG fills the second screen as I hoped.  Thank you for the guidance.

    I was also able to get my PinDMDv3 to display the DMD from Future Pinball tables, so that is a plus.  Now moving on to installing and testing the PinEvent files.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

©2020 VPinBall.com

Log in with your credentials

or    

Forgot your details?

Create Account

The Vpinball app

FREE
VIEW