This topic contains 12 replies, has 4 voices, and was last updated by  Thalamus 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #77220
     Joey2001 
    Participant
    Member

    I have installed the PinUp Player several times. I see Terry’s install videos, but I have one problem.

    The DMD always open on my playfield. I tested this in Tron and Attack from Mars.

    If I start the “PinUpPlayerConfigDisplays.bat” the DMD is correct at the backglass.

    I installed the newest version. I have Freezy’s “DmdDevice.dll” version 1.6.1. I mark “Use external DMD”.

    So I hope, someone can tell me, why the DMD isn’t open at the backglass, if I start the tables from VP.

    Attachments:
    #77226
     TerryRed 
    Moderator
    MemberContributorModerator

    I have installed the PinUp Player several times. I see Terry’s install videos, but I have one problem. The DMD always open on my playfield. I tested this in Tron and Attack from Mars. If I start the “PinUpPlayerConfigDisplays.bat” the DMD is correct at the backglass. I installed the newest version. I have Freezy’s “DmdDevice.dll” version 1.6.1. I mark “Use external DMD”. So I hope, someone can tell me, why the DMD isn’t open at the backglass, if I start the tables from VP.

    That is the virtual DMD from dmdext

    You need to configure where you want it to be positioned (or disable it if you use a real dmd)…all which is configured in dmdevoce.ini

    #77229
     Mark70 
    Participant
    Member

    Hi Joey, it is in this part of the dmddevice.ini:

    The values are an example from my setup.


    Some users who have liked this topic:

    • avatar
    Attachments:
    1 user thanked author for this post.
    #77234
     Joey2001 
    Participant
    Member

    Thanks, I read this in Mark’s thread with his problems and tested it also.

    I could write, what I want. If I open the table it is always the same.

    Changes are written, but ignored.

    My ini-File:

    [global]
    ; how to downscale SEGA 192×64 pixel games to smaller displays: fit, fill or stretch
    resize = fit
    ; flips the image horizontally
    fliphorizontally = false
    ; flips the image vertically
    flipvertically = false
    ; enable or disable frame-by-frame colorization (inactive in VPX bundle)
    colorize = true

    ; a DMD that renders with nice dots on a computer monitor
    [virtualdmd]
    enabled = true
    ; virtual dmd stays on top of all other windows
    stayontop = false
    ; hide the resize grip
    hidegrip = false
    ; ignore the aspect ratio of the rendered dots when resizing
    ignorear = false
    ; use VPM’s registry values when positioning the virtual dmd
    useregistry = false
    ; x-axis of the window position
    left = 2432
    ; y-axis of the window position
    top = 944
    ; width of the dmd in monitor pixels
    width = 1024
    ; height of the dmd in monitor pixels
    height = 256
    ; scale the dot size (set to 0.8 for same size as pre-1.6.0)
    dotsize = 0.8

    [pindmd1]
    ; if false, doesn’t bother looking for a pinDMD1
    enabled = false

    [pindmd2]
    ; if false, doesn’t bother looking for a pinDMD2
    enabled = false

    [pindmd3]
    ; if false, doesn’t bother looking for a pinDMD3
    enabled = false
    ; COM port, e.g. COM3
    port =

    [pin2dmd]
    ; if false, doesn’t bother looking for a PIN2DMD
    enabled = false

    [browserstream]
    ; if enabled, stream to your browser in your LAN
    enabled = false
    port = 9090

    [vpdbstream]
    ; if enabled, stream DMD to https://test.vpdb.io/live
    enabled = false
    endpoint = https://api-test.vpdb.io/

    ; if enabled, writes frames to an .avi file
    enabled =true
    ; path to folder or .avi file. if folder, gamename.avi is used.
    path =PinUP

    enabled=true
    path=PinUP

    #77255
     Mark70 
    Participant
    Member

    You could try to set:
    “use VPM’s registry values when positioning the virtual dmd useregistry = false” to “true” and see if that moves your dmd


    Some users who have liked this topic:

    • avatar
    #77338
     Joey2001 
    Participant
    Member

    You could try to set: “use VPM’s registry values when positioning the virtual dmd useregistry = false” to “true” and see if that moves your dmd

    Thanks, but I try that also. No change. The DMD is always opened on the playfield at position 0,0. I give up, because I don’t know, what else I can try. :wacko:

    #77340
     Thalamus 
    Participant
    ContributorMember

    Didn’t you a one time install dmdext to system folders ? You are sure that the old stuff is cleaned out properly ?

    1 user thanked author for this post.
    #77341
     Mark70 
    Participant
    Member

    I am sure you already cheked that, but could there still be a another dmddevice.ini somewhere on your system?
    I mean in addition to the one that has to be in vpinmame folder.
    Don’t give up, you will get it running

    1 user thanked author for this post.
    #77345
     Joey2001 
    Participant
    Member

    Didn’t you a one time install dmdext to system folders ? You are sure that the old stuff is cleaned out properly ?

    I Think so. :scratch:

    #77348
     Joey2001 
    Participant
    Member

    I am sure you already cheked that, but could there still be a another dmddevice.ini somewhere on your system? I mean in addition to the one that has to be in vpinmame folder. Don’t give up, you will get it running

    I will search tomorrow, if there is another one. :yes:

    #77434
     Joey2001 
    Participant
    Member

    OK, guys, i’ve got it. It was really, that I have more .ini.

    I have it in the UltraDMD- and the Unit3D-Install-Folder.

    I delete it there and now the DMD is where it has to be. :yahoo:

    Thanks for your help.

    :good:


    Some users who have liked this topic:

    • avatar
    • avatar
    #77443
     TerryRed 
    Moderator
    MemberContributorModerator

    Glad you got it working.

    When I say in my setup videos, that you need to make sure you don’t have any dmdext files anywhere else except for vpinmame…. this is the reason why.

    This is from bad habits that fixed other problems last year easily but cause issues with other programs. Not a problem if you know what you are doing, and you can keep track of it all.


    Some users who have liked this topic:

    • avatar
    1 user thanked author for this post.
    #77444
     Thalamus 
    Participant
    ContributorMember

    Well. Guys that follows Bambi’s FAQ surely will have :wacko:

    Fortunately, it is living document. But, I was amazed when I saw the recommendation to how to install eg. dmdext.


    Some users who have liked this topic:

    • avatar
    1 user thanked author for this post.
Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

©2018 VPinBall.com

WP Facebook Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account