This topic contains 15 replies, has 5 voices, and was last updated by  STAT 1 week, 4 days ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #120286
     STAT 
    Participant
    MemberContributor

    Hi Guys,

    please someone can help out here, i am frustrated … had a HDD Crash, and with a small Backup and
    some Files from damaged HDD, now i have a fresh Win 10 SSD in my Cab, well .. all is working again.

    Except the VPinSPA … you know what it is … and i don’t ask here for the Files, no i have it all.
    On my Cab, i always get the “Failed to load DLL” Error – over VPin Test – of Course also with VPX.

    Yeah, and what the Hell – i tried it out on my Laptop #2, and … was working.
    But not on Cab … both are Win 10 64Bit … maybe there is a missing Install like .NET/C++, whatever … :unsure:

    So please, someone had the “Failed to load DLL” – and could solve it / know how to solve ? :cry:

    #120292
     Oldschool4 
    Participant

    I had a similar issue solved it by setting ddraw to 0. Same operating sysytem also. .net 2010 and 2012?

    #120327
     STAT 
    Participant
    MemberContributor

    2010, 2012 installed, yes …

    #120330
     Oldschool4 
    Participant

    I check event veiwer in windows,said .net prob,but already installed,ddraw to 0 solved.reinstall,?double check.It something simple always.

    #120333
     STAT 
    Participant
    MemberContributor

    Can you quick explain, how to set “ddraw to 0” ? Very often read, but never needed … probably until now … :scratch:
    Reinstall what, VPinSPA ? Yes …
    Never used “Event Viewer” … ?

    Thanks for your help :good:

    #120340
     Oldschool4 
    Participant

    Explained on this site,open up command prompt as administrator,navigate to HKEY_CURRENT_USER\Software\Freeware\VisualPinmame\Spagb_100

    Look for ddraw in list,if it is 1 change to 0.

    1 user thanked author for this post.
    #120341
     Thalamus 
    Moderator
    ContributorMemberModerator

    Are you using force fullscreen then Stat ? Anyway – what he is talking about is almost explained completely here :

    https://vpinball.com/wiki/visual-pinball-knowledge-base/reset-a-table-to-default/ – in this case the rom is of course the rom from the table and the setting on the right you want to double click and change is ddraw. But, I would be surprised to learn that this is the culprit. Give it a try, can’t hurt.

     

    1 user thanked author for this post.
    #120343
     STAT 
    Participant
    MemberContributor

    Ah ok Regedit, ok … tried delete, and Restart “Rom”, and also with ddraw to 0,
    no success, “Failed to load DLL” again …

    Thalamus, Force Full – no, because all other Tables are fine, i bet also this one, exc. i can’t load VPin … …  :unsure:

    #120345
     STAT 
    Participant
    MemberContributor

    Live from Cab  :bye: …  :cry:

    Failed

    #120347
     STAT 
    Participant
    MemberContributor

    VPin

    #120350
     Oldschool4 
    Participant

    I have C++ 2008 x64 -x86, 2010 x64 x86. 2012 x64 x86, 2013 x64 x86. Restart system. then reinstall dll. I think it only needs x86, but more wont hurt. :wacko:

    #120467
     STAT 
    Participant
    MemberContributor

    I also thinking about a missing _x86 Part …

    #120470
     STAT 
    Participant
    MemberContributor

    Got it ! Thanks to all here for your Help !

    Especially a big thank you very much to @slippifishi , yes there was a missing _X86 Install, what i needed.

    I only have the Black Bar, right to the DMD but with “Use external” i get the DMD only.

     

    #120485
     slippifishi 
    Participant

    Glad you got it working buddy, I was worried I might have problems if/when I ever format my cab :)

    For the record, the original redist file posted in the original thread has the following properties:

    redist

    There is a copy of this file on the following google share, though beware this link will not last forever so get it while you can:

    https://drive.google.com/open?id=1-CGYVTqru2N6IGAKbYK8ZAaleMTcXK82

    :good:

    1 user thanked author for this post.
    #130963
     Rehab 
    Participant

    Glad you got it working buddy, I was worried I might have problems if/when I ever format my cab :)

    For the record, the original redist file posted in the original thread has the following properties:

    redist

    There is a copy of this file on the following google share, though beware this link will not last forever so get it while you can:

    https://drive.google.com/open?id=1-CGYVTqru2N6IGAKbYK8ZAaleMTcXK82

    :good:

    Hi, I also get the “Failed to load <path> SternGB.dll”-error. What was missing and how did you fix it?

     

    Thanks!

    Zheks

    #130965
     STAT 
    Participant
    MemberContributor

    Download from the Google Drive Link above, install and try again.

    And give a “Thanks” to slippifishi :bye:

    1 user thanked author for this post.
Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

©2019 VPinBall.com

WP Facebook Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account