This topic contains 13 replies, has 5 voices, and was last updated by  mon72 4 days, 1 hour ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #126640
     zimbakin 
    Participant

    This is kind of System and more FX3 related.

    – Freezy 1.7.1
    – Pinup system 1.4.1
    – real DMD

    Using default FX3 emulator loading script (using legacy),
    —> DMD doesn’t work in FX3

    – Upgrade to Freezy 1.7.2 (don’t have to run DMDExt as admin)
    – Pinup system 1.4.1
    – real DMD

    If I run
    “dmdext mirror –source=pinballfx3 –no-virtual”
    as a batch script on startup before loading Pinup system, then my pinDMD2 works perfectly in FX3 (and VPX).
    —> DMD works!! in FX3

    However, if I update the PUP System launch script to the same non legacy as abaove… it doesn’t work.
    Also tried both legacy, non legacy and tried leaving default PinupSystem 1.4.1 script + Freezy 1.7.1 and 1.7.2, nothing works. Only running my separate BAT script at startup works (with PinDMD2).

    The workaround is fine, however would be better if the script could load within the emulation launch script window to keep everything in the system.

    Anyway… for anyone else having issues with DMD in FX3, this may help.

    #126643
     NailBuster 
    Moderator
    ModeratorMember

    yeah,  its a dmdext issue and timing.

    like if you start fx3 and then put

    timeout 10

    dmdext…etc

    so dmdext starts after 10 seconds of fx3 it should work… that’s the workaround i hear works.  I use legacy mode 1.7.1 for now as I have way too many issues with new fx3 tables and dmdext.

    1 user thanked author for this post.
    #126647
     randr 
    Keymaster
    ModeratorMember

    I too use batch  script on startup before loading Pinup system seems to work fine here. I am using 1.72mjr modded version of freezy and running pindmd2 if that matters

    ********************************************************
    Messing with the VPinball app and push notifications.
    So if you haven't downloaded app yet what are you waiting for!?
    *******************************************************

    1 user thanked author for this post.
    #126653
     zimbakin 
    Participant

    At one point I added timeout 3 seconds and couldn’t get it to work. Looks like I was out by 7 seconds LOL.

    #126675
     outhere 
    Participant
    MemberContributor

    I have a Pin2DMD
    I do not run dmdext.exe as admin
    No batch File
    I use Freezy 1.7.3 from here
    https://vpinball.com/forums/topic/freezy-dmd-question/#post-115676

    My PUP System launch script

    rem remove rem to setup your DMDEXT press “open examples for more info”
    cd “E:\Visual Pinball\VPinMAME”

    start /min “” “dmdext.exe” mirror –source=pinballfx3 -q -d pin2dmd –pinup PINUP\[GAMENAME]

    START “” “[STARTDIR]Launch\VPXSTARTER.exe” 5 1 9 “PinballFX3Launcher”

    START “” “[DIREMU]\PinballFX3Launcher.exe” -table_[GAMENAME]

    1 user thanked author for this post.
    #126682
     NailBuster 
    Moderator
    ModeratorMember

    @outhere :  interesting… i guess using that fx3 launcher is a ‘delay’ in itself so helps with timing.

     

    #131196
     mon72 
    Participant

    Hi

    How would the launch script look with the delay time out look

    I get everything up but I need to start like three times to get pup-pack to start in aliens

    this is what I just tried with out luck…

    @echo off
    rem remove rem to setup your DMDEXT press “open examples for more info”
    cd “C:\pinball\Visual Pinball\VPinMAME”
    start /min “” “dmdext.exe” mirror –source=pinballfx3 –fx3-legacy -q -d virtual –virtual-hide-grip –virtual-position=7680 66 1280 654 –pinup PINUP\[GAMENAME]
    START “” “[STARTDIR]Launch\VPXSTARTER.exe” 5 5 20 “Pinball FX3”
    START “” “[DIREMU]\steam.exe” -applaunch 442120 -table_[GAMENAME]

    br

    mon72

     

    #131237
     NailBuster 
    Moderator
    ModeratorMember

    timeout of 10 seconds

    <span style=”font-family: arial, helvetica, sans-serif;”>START “” “[STARTDIR]Launch\VPXSTARTER.exe” 5 5 20 “Pinball FX3”</span>
    <span style=”font-family: arial, helvetica, sans-serif;”>START “” “[DIREMU]\steam.exe” -applaunch 442120 -table_[GAMENAME]</span>

    <span style=”font-family: arial, helvetica, sans-serif;”>timeout 10</span>

    <span style=”font-family: arial, helvetica, sans-serif;”>cd "C:\pinball\Visual Pinball\VPinMAME”</span>
    <span style=”font-family: arial, helvetica, sans-serif;”>start /min “” “dmdext.exe” mirror –source=pinballfx3 –fx3-legacy -q -d virtual –virtual-hide-grip –virtual-position=7680 66 1280 654 –pinup PINUP\[GAMENAME]</span>

     

    #131756
     mon72 
    Participant

    I have tried a lot of variations and i just cant get it to work…
    I had it working after i started and stopped and started over again a few times… so i know it works it just wont start at start if you know what i meen…
    I get the start video for aliens the yellow dmd video starts running and then the dmd goes almost blank, you can see the dmd dots but it is not lit… after a short while it goes black and stays black. I get the alien backglas video frame but no video is running.
    Should I have any special setting in the pup-pack editor? for DMD on off forced…

    I think my problem is a timing issue

    br

    Mon72

    #132077
     mon72 
    Participant

    Anybody who have any suggestions ?

     

    #132078
     mon72 
    Participant

    This is how my Aliens pup-pack looks… is this correct?

    IMG_3559

     
    Can any one please give me feedback if my puppack is correct in the editor…
    Br
    Mon72

    • This reply was modified 4 days, 2 hours ago by  mon72.
    • This reply was modified 9 hours, 21 minutes ago by  mon72.
    #132082
     outhere 
    Participant
    MemberContributor

    To post a picture click on the icon top Right

    #132086
     mon72 
    Participant

    I had a lot of problems with the format… Thanks for the heads up…

     

    #132092
     mon72 
    Participant

    Log

    [1] 2019/06/13 20:05:11.328  INFO | Launching console tool.
    [1] 2019/06/13 20:05:11.539  INFO | Added virtual DMD renderer.
    [1] 2019/06/13 20:05:11.557  INFO | PinUP DLL starting PINUP\Aliens…
    [1] 2019/06/13 20:05:11.583  INFO | Resizing virtual DMD to 128×32
    [1] 2019/06/13 20:05:11.590  INFO | Setting up Render Graph for 2 destination(s)
    [1] 2019/06/13 20:05:11.600  INFO | Connecting Pinball FX3 to Dmd (ColoredGray2 => Rgb24)
    [1] 2019/06/13 20:05:11.600  INFO | Capturing at 25 frames per second…
    [1] 2019/06/13 20:05:11.615  INFO | Waiting for Pinball FX3 to spawn…
    [1] 2019/06/13 20:05:11.657  INFO | Connecting Pinball FX3 to PinUP Writer (ColoredGray2 => Bitmap)
    [1] 2019/06/13 20:05:11.657  INFO | Press CTRL+C to close.
    [3] 2019/06/13 20:05:21.657  INFO | Frames coming in from Pinball FX3.

    PUP-LOG

    20190613 20:05:11 Open called
    20190613 20:05:11 Set Game Name thread Aliens
    20190613 20:05:11 Set B2S init
    20190613 20:05:21 Start Thread Matching
    20190613 20:05:21 create PuPCap
    20190613 20:05:21 Init Game name:Aliens
    20190613 20:05:21 Create Object Display
    20190613 20:05:21 imagedir:C:\Pinball\PinUPSystem\PuPVideos\Aliens\PuPCapture
    20190613 20:05:21 num images 69

     

     

    • This reply was modified 4 days, 1 hour ago by  mon72.
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

©2019 VPinBall.com

WP Facebook Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account