Currently, there are 0 users and 0 guests visiting this topic.
Viewing 20 posts - 1 through 20 (of 25 total)
  • Author
    Posts
  • #147564
    edasner
    Participant
    @edasner

    Apologies in advance for my ignorance, and my many thanks to all of you who work on virtualizing the pinball experience and preserving an important part of history.

    I’m trying to get my DMD to appear in fullscreen mode in VPX using any table in my library.

    When VPX starts, the DMD is in a separate window I see when I hold Alt-Tab to switch windows.  It’s working, but doesn’t appear in the fullscreen window of the table.  I’ve tried changing the stayontop = false in DMD Device config but still nothing.

    I’ve tried every manner of Google search and there’s nothing clearly working.  I would even be willing to go windowed mode but it’s frustrating playing a cabinet without the DMD.

    Can anyone please help? :wacko:

    #147574
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    Post your DmdDevice.ini

    1 user thanked author for this post.
    #147579
    edasner
    Participant
    @edasner

    [global]
    ; how to downscale SEGA 192×64 pixel games to smaller displays: fit, fill or stretch
    resize = fit
    ; flips the image horizontally
    fliphorizontally = false
    ; flips the image vertically
    flipvertically = false
    ; enable or disable frame-by-frame colorization (inactive in VPX bundle)
    colorize = true

    ; a DMD that renders with nice dots on a computer monitor
    [virtualdmd]
    enabled = true
    ; virtual dmd stays on top of all other windows
    stayontop = true
    ; hide the resize grip
    hidegrip = false
    ; x-axis of the window position
    left = 0
    ; y-axis of the window position
    top = 0
    ; width of the dmd in monitor pixels
    width = 1024
    ; height of the dmd in monitor pixels
    height = 256

    [pindmd1]
    ; if false, doesn’t bother looking for a pinDMD1
    enabled = true

    [pindmd2]
    ; if false, doesn’t bother looking for a pinDMD2
    enabled = true

    [pindmd3]
    ; if false, doesn’t bother looking for a pinDMD3
    enabled = true
    ; COM port, e.g. COM3
    port =

    [pin2dmd]
    ; if false, doesn’t bother looking for a PIN2DMD
    enabled = true

    ; if enabled, writes frames to an .avi file
    enabled = false
    ; path to folder or .avi file. if folder, gamename.avi is used.
    path =

    #147602
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    More info
    https://github.com/freezy/dmd-extensions

    When the game is running hit F1 make sure external DMD is checked

    Areas in red set to false
    Areas in Blue Are for setting the location and the size of the DMD

    [global]
    ; how to downscale SEGA 192×64 pixel games to smaller displays: fit, fill or stretch
    resize = fit
    ; flips the image horizontally
    fliphorizontally = false
    ; flips the image vertically
    flipvertically = false
    ; enable or disable frame-by-frame colorization (inactive in VPX bundle)
    colorize = true

    ; a DMD that renders with nice dots on a computer monitor
    [virtualdmd]
    enabled = true
    ; virtual dmd stays on top of all other windows
    stayontop = true
    ; hide the resize grip
    hidegrip = false
    ; x-axis of the window position
    left = 0
    ; y-axis of the window position
    top = 0
    ; width of the dmd in monitor pixels
    width = 1024
    ; height of the dmd in monitor pixels
    height = 256

    [pindmd1]
    ; if false, doesn’t bother looking for a pinDMD1
    enabled = true

    [pindmd2]
    ; if false, doesn’t bother looking for a pinDMD2
    enabled = true

    [pindmd3]
    ; if false, doesn’t bother looking for a pinDMD3
    enabled = true
    ; COM port, e.g. COM3
    port =

    [pin2dmd]
    ; if false, doesn’t bother looking for a PIN2DMD
    enabled = true

    ; if enabled, writes frames to an .avi file
    enabled = false
    ; path to folder or .avi file. if folder, gamename.avi is used.
    path =

     

    1 user thanked author for this post.
    #147687
    edasner
    Participant
    @edasner

    Nope, nada. :cry:   Made all the changes above, still did nothing.

    Using South Park as an example, the table works fine, the DMD works fine, and the DMD shows up as a separate borderless window/process in the upper right corner of my desktop.  The only thing that’s visible when the table comes up fullscreen is the brick background with the outline of the table theme.

    #147688
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    You’re running a single monitor desktop or a cab?

    Any chance you can post a picture of what you’re trying to say

    if you’re not sure click on the icon at the top right for posting pictures

    1 user thanked author for this post.
    #147697
    edasner
    Participant
    @edasner

    Sorry I thought I had posted this earlier, but I’ll try a different way:  https://imgur.com/a/lOcaxTE

    In the first image, you can see the DMD and table processes are working fine.

    In the second image, you can see when I switch back to full screen, the upper right where the DMD is supposed to be is not there.  To be clear:  the DMD can be switched to and is borderless, but then I don’t see the table when I switch back to it.

    EDIT: In the third image, you can see the DMD window as it appears on my desktop, over my browser.  I would expect it to appear up and to the left of the table at the same time, but no dice.  Right place, but doesn’t overlap.

    EDIT 2:  Running single monitor, 1920×1080 from a GTX960 Core i7

    #147703
    naeromagus
    Participant
    @naeromagus
    Member

    If your running only virtual Dmd. Pindmd 1-3 should be set as false.

    1 user thanked author for this post.
    #147705
    edasner
    Participant
    @edasner

    If your running only virtual Dmd. Pindmd 1-3 should be set as false.

    I did all that.  Made no difference in the table.  I had already turned off “Use External DMD” but switching it on, resetting, then switching it off and resetting again did nothing.

    Current settings here: https://imgur.com/JwW7CGs

    #147722
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    In the F1 menu turn off show DMD and turn on external

    Then go to your device DmdDevice.ini file and adjust those areas in blue to where you want it

    1 user thanked author for this post.
    #147727
    edasner
    Participant
    @edasner

    Turned off Show DMD, turned on external, same result – doesn’t appear on top of the table.

    Changed X and Y location in the DMD ini file, same result no matter what values I put in, positive, zero or negative, up to the limits of my display resolution.

     

    :wacko: :wacko:   :wacko:

    #147728
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    What is the location of your DmdDevice.ini file

    1 user thanked author for this post.
    #147760
    Badazzwi
    Participant
    @badazzwi
    Member

    Did you have a working setup at any point or is this a fresh setup?

    Hi my name is Barry and I'm a virtual pinball addict.

    1 user thanked author for this post.
    #147802
    edasner
    Participant
    @edasner

    What is the location of your DmdDevice.ini file

    C:\Visual Pinball\VPinMAME\DMDext

     

    Did you have a working setup at any point or is this a fresh setup?

    Fresh, using VPX 10.6 Installer

    #147806
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    Download the x86 file and unzip it in your VPinMame folder and adjust the InI file and should start to work
    https://www.7-zip.org/
    Right click the zip file before unzipping And make sure the file is not block
    C:\Visual Pinball\VPinMAME\
    https://github.com/freezy/dmd-extensions/releases/tag/v1.7.1

    1 user thanked author for this post.
    #147808
    edasner
    Participant
    @edasner

    Updated the DMD with the 1.7.1 release in the \Visual Pinball\VPinMAME directory, and it also made no difference…

    #147809
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    Post the new DmdDevice.ini file

    1 user thanked author for this post.
    #147818
    Loganchihuahua
    Participant
    @chihua07
    Member

    As far as I have had experience, you need the freezy 1.71 dll and the DmdDevice.ini in C:\Visual Pinball\VPinMAME\.. Not \dmdext\

     

    Also in dmddevice.ini you can try ;

    hide the resize grip
    hidegrip = true

     

    #147820
    edasner
    Participant
    @edasner

    OK…it looks like it’s mostly fixed!

    To summarize, the solution to no DMD in single monitor in VPX 10.6 was:

    What doesn’t work now is hitting F1 to bring up options for the table.  Very strange.

    #147821
    outhere
    Moderator
    @outhere
    MemberContributorvipModerator

    What game or all

    1 user thanked author for this post.
Viewing 20 posts - 1 through 20 (of 25 total)
  • You must be logged in to reply to this topic.

©2020 VPinBall.com

Log in with your credentials

or    

Forgot your details?

Create Account

The Vpinball app

FREE
VIEW