Currently, there are 0 users and 0 guests visiting this topic.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #100882
    VPinKrusty
    Participant
    @vpinkrusty

    Hello world,

    since my diy VPin is set and ready to go I installed the fantastic PinUp as my front end of choice. But now I need to ask for a little help.

    My cab is equiped with a PinControl 2 board and to this I connected most of my arcade and flipper buttons. Using Win 10 Pro, this works well with my 3 screen setup and VPX 10.5.

    But when I enter the PinUp front end sometimes Windows just gives me a “beep” sound when a key is pressed (e.g. “right shift” and/or “left shift” to scroll my list) and nothing more. After some keystrokes I can get to scroll trough the menu normally but the “beep” problem may occur again randomly.

    Since this only happens when PinUp is involved I hope that this is something you guys have a solution for.

    Any help is highly appreciated!

    Kind Regards

    Matt

    #100883
    nFozzy
    Participant
    @nfozzy

    pressing shift 5 times activates stickykeys, you have to turn it off in windows

    #100884
    Seraph
    Participant
    @seraph

    Hey Matt,

    Could it be that STICKY KEYS is on ?

    Beeps when you press shift key 5 times

    disable under ease of access control panel

     

    Or is it possible you have a usb keyboard/device that is turning itself off ?

    Check in your power options (advanced options) that USB selective suspend is disabled

     

    Hope that sorts it for you !

    Edit:   Laughs NFozzy already had you sorted !

    1 user thanked author for this post.
    #100885
    VPinKrusty
    Participant
    @vpinkrusty

    Hi and thanks for your quick replies!

    Sticky keys was and still is disabled.

    The USB power saving setting is now deactivated, I’ll try that. But will Windows power down a device that is used at the same time (PinControl in this case)?

    Kind regads

     

    #100890
    VPinKrusty
    Participant
    @vpinkrusty

    Ok, just a quick update.

    There seems to be an issue with the “Left Shift” and “Right Shift” keys!

    I assigned them like the default configuration in VPX 10.5. Which is a must since the PinControl board inevitably expects these keys to be flipper left and right

    I figured out that when assigning the “Game Next” and “Game Prior” buttons in PinUp to let’s say “Left CTRL” and “Right CTRL” – that are assigned to left and right Magnasave in VPX -, no more beeps till now!

    The only “trouble” this causes is that I need to chose the game in the front end with my Magnasave buttons instead of the Flipper buttons.

    But that is ok with me as long it causes no beeps  :-) .

    #100892
    NailBuster
    Moderator
    @nailbuster
    ModeratorMember

    my guess, is that you had two functions using the same keys… which is a feature but if used wrong can cause strange issues like this.

    like assigning “game next” and “page next” to same left-shift.   so dbl-check that the left-shift wasn’t also assigned to another function…but again, im guessing.

    either way, you have a working solution now…enjoy!

    1 user thanked author for this post.
    #100909
    nFozzy
    Participant
    @nfozzy

    Sticky keys was and still is disabled.

    Make sure the keyboard shortcut for toggling stickykeys is disabled too in the options

    that’s all I got

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

©2020 VPinBall.com

Log in with your credentials

or    

Forgot your details?

Create Account

The Vpinball app

FREE
VIEW