Currently, there are 0 users and 0 guests visiting this topic.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #195281
    Shadow
    Participant
    @shadowshd

    Hi guys,

    It’s been a long time I haven’t switched on my pincab and as I’m on vacation I’m updating it.

    Sorry if it has already been answered and/or if I missed something, but I can’t find a working fix for this issue : PinUp Menu is only working with my Pin2DMD with Lucky1’s DMDDevice.dll.

    I did all updates I could do (Windows 10 2004 x64, PinUp System 1.4.5, Freezy’s DMDDevice 1.8.0, SAMbuild 3.3 r5087, Pin2DMD firmware 3.15…), checked that DMDDevice.ini was correct according to Nailbuster’s doku, re-register everything (PUPDMDControl_register.bat…), removed every “Run as admin” on exe files, tried libusb driver instead of WinUSB, but still no display on my Pin2DMD in PinUp Menu.

    Note that Freezy’s DMDDevice.dll works great with VPX.

    When I launch PopperDoctor/Start DMD I see the DMD test on my playfield screen but not on my Pin2DMD, and when I click on Stop DMD I’ve got a “RPC service isn’t available” error.

    If I put back Lucky1’s DMDDevice.dll, everything runs with no issues…

    So thanks for any tip that could help me.

    #195405
    Shadow
    Participant
    @shadowshd

    OK answering myself as the issue is solved by disabling Windows 10 UAC in registry.

    It was the last thing I didn’t do because I didn’t believe it will fix it, as everything ran smooth before, but I guess that Windows 10 major updates are pushing security systems at more and more higher levels everytime and cause more and more issues for us, virtual pinball users…

    Things that were true with previous Windows 10 builds become false with newer and vice versa…

    I’ve also configured Pinup for DMD video playback by following this step of the Wiki and now everything runs smoothly.

    Thanks and have a nice day ;)

    #195414
    LynnInDenver
    Participant
    @lynnindenver
    Member

    The only problem with disabling UAC is that there are many things in Windows now that expect UAC to be running, even if at the “minimal security” settings, and break when it’s actually switched off.

    Creator of the first PinupPlayer PostDMD mods for VPX - PostDMD for Masters of the Universe VPX and Jaws VPX.
    Head Proprietor of Pisces Pinball, a VPX table developer.
    Lead Technician of MC Chase Amusements, a private arcade in our home basement.

    1 user thanked author for this post.
    #195450
    Shadow
    Participant
    @shadowshd

    Thanks @LynnInDenver ;)

    You’re right disabling UAC is not a future proof option, so after more digging I finally achieved to make everything run with UAC enabled :yahoo:

    When I launched PinUpMenu.exe as admin, my DMD was working but not DOF, and as non admin DOF was working but not my DMD.

    I’ve triple-checked everything on Pinup Wiki, at least I thought… I’ve let one file with Run as admin option : PUPDMDControl.exe in my C:\Visual Pinball\VPinMAME folder.

    I’ve disabled this option and everything runs with no issues, at least I want to believe to it :yes:

    What fools me, and it’s not the first time I’m facing such issues, is that I use Total Commander since many years (as a former Amiga user I never could work with Windows Explorer…), and Total Commander always run as admin, and thus every exe I launch from it also run as admin…

    I just thought about it as I’ve had an issue when PinUp System was launched, and it was because I launched exes from Total Commander.

    I launched PopperDoctor from Windows Explorer, clicked on Start DMD and got a privilege error on PUPDMDControl.exe. I’ve checked this file and bingo, Run as admin was ticked.

    Note to myself and for the future : if something doesn’t work, work with Windows Explorer or run TC as non admin ;)

    #196694
    austinwilli
    Participant
    @austinwilli

    Shadow,

    Any other suggestions?- I am running into a very similar issue (just posted) – I tried everything you mentioned.

    #196789
    Shadow
    Participant
    @shadowshd

    I’ve just read your topic and have no other suggestions than Nailbuster, sorry…

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

©2021 VPinBall.com

Log in with your credentials

or    

Forgot your details?

Create Account

The Vpinball app

FREE
VIEW