This topic contains 178 replies, has 62 voices, and was last updated by  Vinthar 2 months ago.

Viewing 19 posts - 161 through 179 (of 179 total)
  • Author
    Posts
  • #87357
     nFozzy 
    Participant

    Version 1.42
    Cleaned up initialization scripting to hopefully reduce errors
    Reworked GI, uses the proper rom-controlled strings again (1.3 had all GI merged together)
    – Has a couple new GI flavors to try, Saves GI colors on exit to VPReg.stg
    Fixed some sidewall reflections and updated masks for the new cab mesh
    Adjusted DT spider angle to be less distorted, adjusted SSFS (on the playfield) spider to be more playable
    Added Sweep target scripting on spell targets


    Some users who have liked this topic:

    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    6 users thanked author for this post.
    #87367
     Ben Logan2 
    Participant
    Member

    Thanks for the quick and thorough update to your recent update!

    #87368
     Thalamus 
    Participant
    ContributorMember

    Thank you for an update on the already great update :good:

    #87481
     RYSr (Rich) 
    Participant

    Figured I’d try this 1.42 version and see if it fixed the script error ” line:1 Object not a collection” that I also got with the 1.4 version.  Still have error.

    Earlier 1.3 version table works fine.

    Checked that VBS files are only in the Scripts directory. have correct SAM.vbs version, latest Vpinmame and VPX betas. Table won’t start so I can’t get a crash log.

    I have it loaded on my desktop and my CAB both have the same error. All other tables working fine.

    I have PinUpPlayer and Freezy’s color DLL’s running, do not run DOF.

    I can just keep using version 1.3, but I hate it when I can’t get to the bottom of a problem.

    Any ideas? What does this script error point to?

    #87489
     Thalamus 
    Participant
    ContributorMember

    @rysr : And you’re 100% sure you don’t have some *.vbs files laying around ? I guess because you can run 1.3 there is indications that it is not the problem. But, still, I would make sure. Because if he has used something that needs new updated script – it could actually explain the problem too.

    You really should try to fix this because I came back here to say that I’m super impressed by these new updates.

    It has always been a great table. But these new updates are great. It is super impressive to change the Gi lights via the flippers and see the reflections on the flippers themselves changes accordingly. Even trapping a ball, they reflect correctly. Wow. So much details I almost forget to play. :wacko:

    Thank you very much nFozzy !! :rose:   :heart:

    1 user thanked author for this post.
    #87494
     nFozzy 
    Participant

    I can reproduce it with an old core.vbs. Your core.vbs is probably outdated.

    Alternatively you could search for this line and delete or comment it out:

    If TiltObjects then vpmnudge.solgameon aEnabled

    1 user thanked author for this post.
    #87496
     HauntFreaks 
    Moderator
    vipContributorMember

    noticed the ball is dribbling out of the spiderhole not being kicked out…

    #87500
     nFozzy 
    Participant

    If you mess with the bsspider settings can you get it to work? If you get it working post the settings here. These are the relevant settings for adjusting the kickout:

    bsSpider.InitKick sw36, 202, 40 ‘Kicker object, Angle, Strength
    bsSpider.KickZ = 95 ‘z angle

    To test it you should be able to paste these lines in the debugger and just throw balls at the spider hole. The script will deal with excess balls and catch any balls that fall off the table.

    #87501
     RYSr (Rich) 
    Participant

    I can reproduce it with an old core.vbs. Your core.vbs is probably outdated.

    Alternatively you could search for this line and delete or comment it out:

    If TiltObjects then vpmnudge.solgameon aEnabled

    @nfozzy

    Thank you for help with this,

    I commented it out:

    If TiltObjects then vpmnudge.solgameon aEnabled

    And the table works now! :yahoo:

    I did a file search for any .vbs files in the Virtual Pinball working directories as well as the VPMame directories, as well as any windows search paths I have setup and I only have VBS files in the Scripts folder. I copied them directly from the VPX_5_rev3434 download. Core VBS is dated 3/24/18 and 130kb size.

    I don’t understand the code in the line you had me comment out, but I do have a physical tiltbob in my cabinet and have over written the nudgePludIn.vbs with MJr’s version. Could that have anything to do with this issue?

    Thank you so much for you reply and help with this, not to mention this wonderful table.

    #87503
     HauntFreaks 
    Moderator
    vipContributorMember

    look like if i set the sw36a/b to legacy with a .9 accuracy   its working perfect

    I also was looking at the GI flashers… now this is maybe just my personal preference….   but if i set all the GI flash like below…. it makes it more like the lighting is under the plastics… again this might just me…

    Attachments:
    #87507
     Thalamus 
    Participant
    ContributorMember

    The nudge plugin got updated in 10.5 some revisions back. If you recently have renamed it, you should be ok. I doubt you have a tilt bob in the other computer so this sounds a bit strange.

    Just rename the mjr once again to be sure. Or, compare them eg. here https://www.diffchecker.com/

    #87512
     RYSr (Rich) 
    Participant

    The nudge plugin got updated in 10.5 some revisions back. If you recently have renamed it, you should be ok. I doubt you have a tilt bob in the other computer so this sounds a bit strange.

    @thalamus

    Your right my nudge plugin.vbs was older, I didn’t realize MJr updated his VBS file. I tried the table without the line remarked out with the newer version of MJr’s vbs file and it works, that was the problem. I guess there was a thread I didn’t keep up on that mentioned the update.. :whistle:

    Boy this was a real head scratcher, thanks Thalamus and nFozzy

    The reason I had the issue on both computers is because I tried MJr’s vbs on the PC to see if it effected the table jumping on my desktop setup and left it there..

    How nFozzy figured out that line would fix it is beyond me, TwlightZone territory. Core.vbs was not the problem..

    #87524
     Thalamus 
    Participant
    ContributorMember

    Oh well. The reason I knew about it is that I had troubles using nFozzy fastflip on the start wars table DjRobX was part of making over on the Italian site. In the end he, being the smart guy among us, understood how to fix it and I made sure that Toxie updated it for the next release. So, not so magic – magic :-)

    #87569
     nFozzy 
    Participant

    Okay new small update.

    The LED skull mod can now be toggled in-game by pressing the right flipper while the left magnasave is held down. I’ll think of a less awkward way of doing this later.

    Version 1.43 –
    Better error warnings and workarounds for some of the reported script errors
    Cleaned up the hole scripts (hopefully this fixes the issues you were having, Hauntfreaks)
    Adjusted the GI and  fixed a few incorrect reflections
    Instruction / Scorecard and skull LED mod preferences now save on exit
    Fixed some issues when running the prototype rom


    Some users who have liked this topic:

    • avatar
    • avatar
    • avatar
    2 users thanked author for this post.
    #87583
     RYSr (Rich) 
    Participant

    Oh well. The reason I knew about it is that I had troubles using nFozzy fastflip on the start wars table DjRobX was part of making over on the Italian site. In the end he, being the smart guy among us, understood how to fix it and I made sure that Toxie updated it for the next release. So, not so magic – magic :-)

    I get a F11 reading of .2ms for the left flipper on this table, is Fast flips code being used in this table? I thought FastFlips was just for SAM tables?…

    #87586
     Thalamus 
    Participant
    ContributorMember

    The non techical story behind it is that nFozzy made script changes which has been updated in 10.5 where quite a lot of the older tables can bypass pinmame flippers. You have to change useSolenoids = 1 to useSolenoids = 2 in the table script to get it to work. So, then DjRobX used the idea to implement it for Stern tables, but that is done by clever pinmame hacking.

    These threads holds more meat to the bone info.

    http://www.vpforums.org/index.php?showtopic=38651&p=387761

    http://vpuniverse.com/forums/topic/3461-sambuild31-beta-thread/?do=findComment&comment=39484

     


    Some users who have liked this topic:

    • avatar
    1 user thanked author for this post.
    #87590
     rothbauerw 
    Participant
    ContributorMembervip

    Change log indicates a FastFlips hack was implemented with version 1.4.

    Current Project: Perpetual updates of Pinball Magic


    Some users who have liked this topic:

    • avatar
    #88076
     Draifet 
    Participant
    Member

    I tried to wait for a “final” release with the updated ramp visuals and the rest of the TODO list done, but couldn’t resist. Thanks for this updates, an already super nice table getting better.

    A minor issue I found, the snake skull is not visible behind the ramp, u need to change the Prim_LeftRampTOY -> Deep Bias: -160 and it appear again.

    The BumperFlashers are clipping a little with the ramp too, u can move them with the BumperCaps primitive a little to the right without gameplay issues I think.


    Some users who have liked this topic:

    • avatar
    #88142
     Vinthar 
    Participant

    Wonderful table. After upgrading to latest ver B2S stopped working and I have some net framework error. Anyone can tell me how to fix this, or can someone share better b2s – the one I am using is from 2013 and I can’t find newer one…

    I tryed to downgrade:

    1.42 – the same net framework error

    1.411 – works ok.

Viewing 19 posts - 161 through 179 (of 179 total)

You must be logged in to reply to this topic.

©2018 VPinBall.com

WP Facebook Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account