This topic contains 164 replies, has 58 voices, and was last updated by  Kingspian 1 month, 3 weeks ago.

Viewing 20 posts - 121 through 140 (of 165 total)
  • Author
    Posts
  • #100027
     dexje 
    Participant

    Is there anything special I need to do to get DOF working on this table?

    Feedback triggered by the flippers works on all tables for me except this one and nFozzys version of Congo.

    DOF is enabled in the b2s settings. I´m running vpx 10.5, piname 3.1.

    Make sure your dof config for star trek matches the rom you are using. In the config tool you can choose the 168 or the 170 rom, from a drop down menu. If not the same switch to correct and generate a new config

    you are correct :) i have never seen a select option before … i changed it to st_161hc and now flipper feedback works.

    Thanks!

    #102437
     erikrom 
    Participant

    genial merci beaucoup  :-)

    archeo gamer

    #108816
     L0stS0ul 
    Participant

    This is the best version of the table by far but I am having the same performance issue as the user quoted below. Basically anytime the vengeance is hit my FPS drops by almost 20 from a solid 60 and I get ball stutter. This does not happen on any of the other st tables. I’m still new at this and I’ve been testing by disabling the vengeance animations and saw no difference so it’s not the animation. My best guess is that there is an extremely bright light that flashes when the ship is hit and that light is causing the fps dip. I disabled the ROM light triggers and tested and that really bright light was stuck on and my fps was stuck at 47. I just can’t find that light in the editor.

    I love this table so much I’m going to keep looking but hopefully someone might have a solution to it. Makes multiball almost impossible when the vengeance is hit.

     

    This is definitely my favorite version of this table for accuracy and visuals (I’m unsure why other versions all seem to use modified Pro outlanes instead of the Premium/LE playfield setup). However, out of all my tables in general, this is the only one that has a lag/stutter anywhere in play. Specifically, when I hit the Vengeance shot I have a massive framerate drop while the ship jumps and lights flash. I know all my software components are up to date and really feel my computer build should have no problems with it, so I’m not sure what is happening with this one. Any suggestions on specific features to adjust without compromising any of the beauty that is this table build?

    #108830
     Jopp 
    Participant
    Member

    My first table to test when I upgraded my PC/vid from 15-3450/HD7950 to AMD Ryzen 5-2600/GTX1070.

     

    Although i would have expected that this new combination can handle the table very easy : when those lights comes in and MB starts there is a huge drop of fps making that part whell..both unplayable but also weird fun.

    Always asked myself why it is..so if there is any solution.. (I also tried to lower the lamp and flasher interval at the BG, this helped with a lot of tables but..not here)….

     

    “It remains a mystery…”

     

     

    My favorite pinball machine?
    Where I can put my name on as G.C....

    #108845
     Mark70 
    Participant
    Member

    @Jopp have you already tried it with “playfield reflections” disabled?

    --------------------------------------------------------------------------------------------------
    I am looking for T2 cabinet decals, please send pm for offers.
    --------------------------------------------------------------------------------------------------

    #108849
     Jopp 
    Participant
    Member

    @Jopp have you already tried it with “playfield reflections” disabled?

    Thanks for the suggestion…checked that but it was ok..
    However…I noticed that the table I had was from a different author…

    Installed this one and this works perfect, also on 4K.  :good:

    Thnks,

    My favorite pinball machine?
    Where I can put my name on as G.C....

    #108870
     L0stS0ul 
    Participant

    My issue is definitely with this table and it is happening on two machines with different setups. I have tried AO and table reflections turned off for it and the fps drop is less but still noticable. Maybe 5-10 fps drop instead of 15-20. It does make the table more playable with multiball but still seeing noticable stutter in the balls. Definitely seems to be related to the lighting but I have not been able to track it down. Again, I don’t see this fps drop in any of the other st:le tables that are available.

    Cab pc specs

    Ryzen 1200 3.1GHz Quad-Core, GTX 1050 Ti 4GB, 8GB DDR4 2400, crucial SSD

    Other pic spec

    Intel i5-7400 3.0GHz, AMD RX 580 4GB, 8GB DDR4 RAM, Samsung ssd

    Latest beta vpx, vpinmame Sam build, vpx 1080p graphics settings on both running in full screen mode.

    I’ll keep turning off stuff in the table until I figure this out.

    #108885
     Jopp 
    Participant
    Member

    @lostsoul:

    as this table works perfect on my setup I can’t give you advice on this one specific but…

    I had simular issues like you describe, what worked for me on those tables (and may-be for you on this table): go to the backglass settings (run table, mouse on BG, right mouse) and you’ll see the BG menu.

    There you’ll see options like GI and flasher frame-skip (I’m not at my cab so might be slightly other naming but you’ll find it).

    Turn those 2 values to the max (I believe it was from the standard 3 up to 30) and with that new setting the problem disappeared.

    My thought is that the lamps (flash?)  lamp in the BG can couse problems with the PF when they are activated. Tot test this I loaded an completely other BG with the problem-table (from a fine working table) and then the problem was gone so it had to do something with the BG….

    Strange thing was that on my slower, older PC the standard value was ok but on my much more faster PC I needed to turn down those value.

    Anyway…good luck with it. :good:

     

    My favorite pinball machine?
    Where I can put my name on as G.C....

    #108890
     L0stS0ul 
    Participant

    I have not played with the backglass so will give that a try and report back. Thanks

    #108932
     L0stS0ul 
    Participant

    I turned off the backglass completely and I am still seeing the issue. I turned on the debug animation code ‘Sub mofo(input)’ for the down arrow key and there is no FPS drop when that is triggered while in play. More testing shows I see the FPS drop when the ‘Sw11col1_Hit’ function is called as well as any time the vengeance is hit otherwise. It does make destroying the vengeance difficult. I did find that if I turn off vertical sync i see less stutter as the FPS are locked at 130fps normally and drop to 80 when the vengeance is it. Downside to that is that I get pretty bad screen tearing so that’s not a viable option. Not sure why my FPS is dropping so low when vertical sync is on.

    At least I’m learning a lot looking at the table code. Comparing to the other ST:LE tables it’s clear that this one has implemented so many more effects and controls from the rom. The other tables look like they just do a random animation and not the realistic ones.

    #108939
     Jesperpark 
    Participant
    Member

    @lostsoul

    Can you post a screenshot of your VP video options?  I tried this table on my computer hooked up to my tv, and only saw frames drop from 60 to 58 when hitting the vengeance.  My CPU is an I3 with 8gm Ram and 750ti graphics card.  Although I’m not running the backglass server on it.  Other than to 2 fps drop everything else plays perfectly for me :scratch:

    BTW, the light you are seeing is the flasher that is located under the vengeance itself in the real game.  Comes on for direct hits to the drop target, also when ready to start MB

     

    #108947
     L0stS0ul 
    Participant

    I do appreciate the help. Here are my settings which are basically the same on both machines. The only real difference is that the amd graphics card requires the alternate depth buffer setting.

    vpx

    For table settings I have the AO turned off and reflections off.

    stle

    My FPS drop is much more dramatic. Only happens on this table with this particular effect. I have 40 other tables on it without issue. Of course this table happens to be my favorite so I see it much more  :unsure: My FPS drop is much more significant than what you see. With v-sync a 10-15fps drop with ao and 5-10 without. Without V-Sync it’s from 130 – 80 fps drop. With the other ST:LE tables I see no FPS drop when the vengeance is hit but as I can see from the code they are completely different beasts so not apples to apples.

     

    #108948
     Thalamus 
    Moderator
    ContributorMemberModerator

    Brute force 4x SSAA. That can be a killer. I know that if of course takes away the ragged edges etc. So, it something that you are trying to prevent. Curious, have you tried turning that off and instead setup 4x DSR via the nvidia graphics settings instead ?

    #108951
     L0stS0ul 
    Participant

    I have not given that a try. Will give it a go right now. Thanks.

    #108952
     L0stS0ul 
    Participant

    ok, I think that was the ticket. I set the force AA unchecked and set vsync to 0 in the vpx settings. In the nvidia settings I set override app for AA to 4 and then set vertical sync to on. Now the FPS is locked at 60 and is far more steady than it has ever been on several tables. Thanks so much!!!!

    #108953
     Thalamus 
    Moderator
    ContributorMemberModerator

    Lol. Ok, actually – that wasn’t exactly what I suggested, but, as long as it works for you :)

    #108955
     Jesperpark 
    Participant
    Member

    Yeah I figured the 4x brute force was going to be the culprit.  Maybe I should of posted my settings, instead of asking for the screen shot. I got distracted doing other things(shopping for pinball parts), and forgot to check back :wacko:

    thanks @thalamus

    #108956
     L0stS0ul 
    Participant

    I really appreciate the help. I’m not sure what the DSR setting is as I did not see a setting in the nvidia control panel for that. Disabling the 4x brute force in vpx does seem to be the solution though and I was even able to force 8x AA from the nvidia control panel along with 4x anisotropic filtering without any drop in FPS at any point. Things are locked at 60fps no matter what table I tried including this one. It really didn’t matter VPX vertical sync or nvidia forced sync the results were the same.

     

    #108959
     Thalamus 
    Moderator
    ContributorMemberModerator

    Happy to hear that. Well, nvidia DSR is more of a poor mans 4k on 1080p monitor thing. https://www.geforce.com/hardware/technology/dsr/technology – who knows. Maybe you can enable that too and still get better results as before. Don’t push your luck too far though – at least do one thing at the time so you know where you where at. I used to play with a 750ti and Carny told me about these setting. It was a life saver for me until i got the nvidia 1080 and went to full blown 4k.

    Since you shared your settings and I saw your ran on 1080p with AA enabled. If you find that setting. Just don’t fiddle to much with smoothness. Instead focus on multiplier. 4x actually is the one that makes most sense, if you can handle it.

    #108974
     L0stS0ul 
    Participant

    I had never heard of that setting before. Gave it a try going 2x screen resolution and turned down the AA to off and it looks great and the FPS are still locked at 60 even during Vengeance multiball. :yahoo:   Thanks so much for the help. I never would have thought that setting be so dangerous.

    I’ve been playing with the settings just to see if I could get it any better. I tried the 4x on the scaling but my graphics card could not handle it. FPS drop was huge even with all other graphic settings turned off. It did look beautiful though. 2x scaling works well without any FPS loss but there is no real visible difference between the nvidia forced 4x AA and the scaled version so I think that ends up being a bit of a wash. When I can afford a new graphics card maybe I can go to the 4k display scaling :)

    Thanks again for the help. I’m one happy camper right now.

Viewing 20 posts - 121 through 140 (of 165 total)

You must be logged in to reply to this topic.

©2019 VPinBall.com

WP2Social Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account