If you're experiencing flipper delay in TPA\PBFX2\VPX on PC…

This topic contains 0 replies, has 1 voice, and was last updated by Profile gravatar of Paulo Carvalho Paulo Carvalho 1 month, 2 weeks ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #45260
    Profile gravatar of Paulo Carvalho Paulo Carvalho 
    Participant

    Hey vpinheads, this fix is something I always adjust in my video card setting after a new driver is installed. Max Pre-Rendered frames should always be set to “1” so you get min delay when playing virtual pinball. I found a good FAQ here below:

    (http://pinballarcadefans.com/showthread.php/6365-If-you-re-experiencing-flipper-delay-in-TPA-PC-version-please-read-this)

    Hi,
    I’m posting this as a separate thread such that it can be easily found and help others also enjoy the PC version of TPA to its fullest.

    I’d been experiencing the flipper delay in fullscreen mode also and it was kind of ruining my Pinball Arcade experience. Luckily there’s a solution for both NVidia and AMD cards that solves this input delay problem for the PC version.

    The flipper delay in fullscreen mode is caused by a mechanic in Windows that sets the number of “back buffer frames” that a driver can queue. Sadly this value defaults to three frames, which is good for watching video, or running a game on heavily underpowered machines, but it is very bad for fast action gaming like pinball, especially when the host PC can easily cope with the vsync update rate of TPA.

    1. Solving it from a user perspective

    Solution for NVidia:
    Go to the control panel and set the global “maximum pre-rendered frames” to 1, as in the following picture:

    Solution for ATI / AMD:
    This is almost unbelievable, but AMD doesn’t provide an option to set this value. Luckily there’s a neat and clean workaround via the “RadeonPro” tool. Download it at http://www.radeonpro.info and set the “Flip Queue Size” in the “Advanced” panel to 0 or 1. You can set this value gobally, or you can create a profile for a single program (TPA in this case):

    2. Solving it from the programmers perspective (possible solution)

    The flipper delay problem can possibly also be solved from the Pinball Arcade side, so this is for Mike and/or Stuart. From your code you can set the maximum frame latency by calling IDirect3DDevice9Ex::SetMaximumFrameLatency method, and change the ridiculously high default value of 3 to a much more sane value of 1. See for a full description the MSDN site here: http://msdn.microsoft.com/en-us/libr…=vs.85%29.aspx. Possibly this value should be configurable from the TPA config utility? I’ve seen blockbuster type of games also doing it that way (I think Metro Last Light also has this configurable from its options).

    Best of luck to all and Happy Gaming!

    [Paulo Carvalho Mobile - 204-294-4389]
    http://www.pinballowners.com/paulohotline
    "Life is like pinball, your always trying to keep your balls in play, but in the end, they drop down the middle :)"

    2+

    Some users who have liked this topic:

    • avatar
    • avatar
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2017 VPinBall.com

Facebook Auto Publish Powered By : XYZScripts.com

Log in with your credentials

or    

Forgot your details?

Create Account