Currently, there are 0 users and 0 guests visiting this topic.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #174493
    fischb
    Participant
    @fischb

    Thanks for the Mega Guide, TerryRed.  My cab has 4K playfield and a 4K backglass monitors, plus a marque monitor for DMD (1920 x 358). I have followed the guide, including display settings: arrangement and dot pitch, etc. with VPX and FX3 running perfectly.

    BAM/Future Pinball will run fine when “Backglass on second monitor” is unchecked in Video setting.

    However, if I check “Backglass on second monitor” FP hangs at the splash/load screen with the word “Processing Registry Entries” (the progress bar never advaces)

    I have proceeded through the guide regarding instructions on setting Arcade Mode, etc.

    Thoughts?

    #174522
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    I saw another post like this somewhere… and I’ll be damned if I can find it now…but I thought they had their solution on it.

     

    For some reason…your system isn’t liking what you have set for your Second Screen. My guess is DISPLAY # related.

     

    Don’t assume the DISPLAY #’s are accurate in FP settings. You may be selecting a monitor ID that may not exist or is the incorrect monitor, even though its the same number as what it shows in Windows. This is a common “Windows” problem that is not specific to FP and can cause headaches…even with VPX. You may need to keep trying different DISPLAY #’s for your backbox,etc until you find the right one that works correctly.

     

    If FP can’t run correctly on your multi-screen setup with these settings (note the rotation is meant for cabinet use), then something else on your system is the problem… whether it’s a GPU driver, and monitor setting, or you may be selecting the wrong DISPLAY to use,etc

     

    You can try making your backbox NOT fullscreen to see where is shows up…if the table loads. You maybe need to remove your settings in the registry… or maybe manually set the right screen and resolution for your backbox there.

    Computer\HKEY_CURRENT_USER\Software\Future Pinball\GamePlayer

     

    #174799
    GeorgeH
    Participant
    @georgeh

    I saw another post like this somewhere… and I’ll be damned if I can find it now…but I thought they had their solution on it.

    I think this is the posting you were thinking about (possibly page 2):

    https://www.vpforums.org/index.php?showtopic=44047&hl=

    Unfortunately, the OP never posted if he was able to fix the problem yet.

    When you say Display #, I assume you mean the “Monitor:” field on the FP “Video / Rendering Options” located just above “Resolution:”.  …So DISPLAY2 could actually be the playfield monitor?

    George

     

    #175334
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    I saw another post like this somewhere… and I’ll be damned if I can find it now…but I thought they had their solution on it.

    I think this is the posting you were thinking about (possibly page 2):

    https://www.vpforums.org/index.php?showtopic=44047&hl=

    Unfortunately, the OP never posted if he was able to fix the problem yet.

    When you say Display #, I assume you mean the “Monitor:” field on the FP “Video / Rendering Options” located just above “Resolution:”. …So DISPLAY2 could actually be the playfield monitor?

    George

    Correct… its a common problem with windows that cabinet users have to deal with at times…and its a pita. It gets worse when screens are disconnected and connected again.

     

    Easiest thing to do is make FP and BG windowed at first until you figure out what is needed. Do the playfiel first, then do the Bg.

     

    He may need to remove FP settings completely in the registry, reboot with all screens connected and working correctly…. then try again.

    #175799
    fischb
    Participant
    @fischb

    Ok, its not a screen ID issue.  Here is the current behavior:

    I can ID the playfield as display 1 and the game starts in a window with or without any and all other options

    I then change the playfield display to Display #2 – no second display selection, just playfield display change).  At startup I get a nice window on display #2 (which is my backglass display)

    But he window remains white and never renders anything

    I also did clear out the registry keys and no luck

    #175980
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    Ok, its not a screen ID issue. Here is the current behavior:

    I can ID the playfield as display 1 and the game starts in a window with or without any and all other options

    I then change the playfield display to Display #2 – no second display selection, just playfield display change). At startup I get a nice window on display #2 (which is my backglass display)

    But he window remains white and never renders anything

    I also did clear out the registry keys and no luck

    Are both monitors connected to the same GPU? If not try that.

    #175982
    fischb
    Participant
    @fischb

    yes single rtx 2080 gpu for all monitors

    #178375
    TerryRed
    Moderator
    @terryred
    MemberContributorModerator

    yes single rtx 2080 gpu for all monitors

    Two other guys had the same problem here on VPinball.

    It turned out they didn’t have their motherboard drivers up to date… and in their case it was the audio drivers that caused this very problem.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

©2020 VPinBall.com

Log in with your credentials

or    

Forgot your details?

Create Account

The Vpinball app

FREE
VIEW