This topic contains 50 replies, has 8 voices, and was last updated by  Tom 5 months, 1 week ago.

Viewing 11 posts - 41 through 51 (of 51 total)
  • Author
    Posts
  • #112947
     Tom 
    Participant
    Member

    I have gone in and deleted the registry for the rom and no change.  I have played with settings on the roms but never with anything else.  I didn’t know if maybe it was a registry setting with vpinmame or vpx.

    It sounds like with talking to other people that they can decide what roms to use external dll and which to not even with vpx so I am not sure that it is a bug in the programming as much as an issue with mine.

    when I play games like totem and other system 1 games the external dll selected gives me scores on my dmd screen that are the same as on the b2s.  , I am able to deselect external dll and  deselect show dmd so that the only scores that come up are on the b2s.  That works fine with no error even in vpx.  If I would do that on a table like afm or 24 say, it gives me that error

    does that make sense?

    #112950
     Thalamus 
    Moderator
    ContributorMemberModerator

    No – not really. What is the exact error you get ?

    #112951
     Tom 
    Participant
    Member

    I am away from home but it’s the same error you get when you don’t have the rom and you launch a table.   I believe it’s “vbscript error,  machine”rom name”……terminated before initialized, check the rom path or rom file.”

    #112952
     Thalamus 
    Moderator
    ContributorMemberModerator

    Hmm. This is a tricky one. Next time you are at the pin. Make sure that exclusive fullscreen is not turned on and see if that changes anything.

    #112954
     outhere 
    Participant
    MemberContributor

    Just getting back to the computer to Post the same idea

    VP preference, video Options
    If using Force exclusive fullscreen then you need to turn off ddraw in a registry under the rom name
    Some people have problems with certain games, they also had to turn this off  — at91jit under the rom name
    I have Ddraw off for all my games whether I use force full screen or not
    In the registry under the Default turn Ddraw off
    Computer\HKEY_USERS\S-1-5-21-3218587510-2525965426-1050287223-1000\Software\Freeware\Visual PinMame

    1 user thanked author for this post.
    Tom
    #112956
     Thalamus 
    Moderator
    ContributorMemberModerator

    I agree. But, then again. He says that he is able to run these with ext-dmd, but, not without. That is the odd part. I’ve done the same as you outhere :)

    #112971
     outhere 
    Participant
    MemberContributor

    I know when I run full screen I don’t have mouse control when you’re in the game I don’t know if that’s normal
    But it sounds like Tom had mouse control

    I checked last night before posting And I was able to run the external DMD with ddraw on….
    Let’s hope that’s the problem or maybe in registry

    #113013
     Tom 
    Participant
    Member

    DING DING DING…We have a winner and his name is Thalamus! Force exclusive fullscreen  Was enabled .  The problem is fixed.  I wish it could have been a more interesting problem but I guess when I switched to 64 bit I selected it on the clean install.  Thanks Thalamaus and Outhere and everyone else for the recommendations.

    Now can someone briefly explain what that does and why it happened and are there any disadvantages in disabling it.

    #113042
     Thalamus 
    Moderator
    ContributorMemberModerator

    It’s and advantage to enable it – gives less stutter I’m told. And again, you need to turn ddraw off in registry to run with it enabled.

    I don’t run with it enabled on a daily basis. I can switch at any time I like though since I, like othere has turned that off for all roms.

    1 user thanked author for this post.
    Tom
    #113058
     outhere 
    Participant
    MemberContributor

    freezys
    I’m assuming you read the whole Topic but just in case you didn’t is this something I’m doing wrong or is there an issue
    Running Windows 10 64 bit
    I am using 32 bit for all
    I’m having the same issue or something very similar
    VP-9 works fine
    If I use alternate settings (Position/size) with (freezy) it will not work with VP-10
    I have tried the 4 different Dll files, they all do the same thing
    If I remove the alternate settings then it works but then it’s not on the screen where I want it
    ;Teenage Mutant Ninja Turtles
    [tmnt_104]
    virtualdmd left = 2455
    virtualdmd top = 673
    virtualdmd width = 720
    virtualdmd height = 62
    The log is the same for Either VP, except for the fact that it says which VP is running

    “””””””I found the problem”””””
    If you have the DPI checked (see image) it will not allow the external DMD to be visible when using relocation settings……………..
    With it unchecked, it worked fine and to be sure…………………..
    I tested the VP-9 and when the DPI is checked the DMD is not visible……………..

    DPI

    1 user thanked author for this post.
    #113063
     Tom 
    Participant
    Member

    My issue is 100% fixed. Full screen back on and ddraw off for those tables not using external dll enabled thanks

Viewing 11 posts - 41 through 51 (of 51 total)

You must be logged in to reply to this topic.

©2019 VPinBall.com

WP2FB Auto Publish Powered By : XYZScripts.com
Vpinball.com

Log in with your credentials

or    

Forgot your details?

Create Account